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DISCLAIMER:

mikroPASCAL PRO for AVR and this manual are owned by mikroElektronika and are
protected by copyright law and international copyright treaty. Therefore, you should treat
this manual like any other copyrighted material (e.g., a book). The manual and the compiler
may not be copied, partially or as a whole without the written consent from the mikroEelk-
tronika. The PDF-edition of the manual can be printed for private or local use, but not for
distribution. Modifying the manual or the compiler is strictly prohibited.

HIGH RISK ACTIVITIES:

The mikroPASCAL PRO for AVR compiler is not fault-tolerant and is not designed, manu-
factured or intended for use or resale as on-line control equipment in hazardous environments
requiring fail-safe performance, such as in the operation of nuclear facilities, aircraft navigation
or communication systems, air traffic control, direct life support machines, or weapons sys-
tems, in which the failure of the Software could lead directly to death, personal injury, or severe
physical or environmental damage ("High Risk Activities"). mikroElektronika and its suppliers
specifically disclaim any express or implied warranty of fithess for High Risk Activities.

LICENSE AGREEMENT:

By using the mikroPASCAL PRO for AVR compiler, you agree to the terms of this agreement.
Only one person may use licensed version of mikroPascal PRO for AVR compiler at a time.
Copyright © mikroElektronika 2003 - 2009.

This manual covers mikroPASCAL PRO for AVR version 1.2.5 and the related topics.
Newer versions may contain changes without prior notice.

COMPILER BUG REPORTS:
The compiler has been carefully tested and debugged. It is, however, not possible to
guarantee a 100 % error free product. If you would like to report a bug, please contact us at
the address office@mikroe.com. Please include next information in your bug report:

- Your operating system

- Version of mikroPASCAL PRO for AVR

- Code sample

- Description of a bug

CONTACT US:
mikroElektronika

Voice: + 381 (11) 36 28 830
Fax: + 381 (11) 36 28 831
Web: www.mikroe.com
E-mail: office@mikroe.com

Windows is a Registered trademark of Microsoft Corp. All other trade and/or services marks
are the property of the respective owners.

MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD



Table of Contents

CHAPTER 1 Introduction

CHAPTER 2 mikroPASCAL PRO for AVR Environment
CHAPTER 3 mikroPASCAL PRO for AVR Specifics

CHAPTER 4 AVR Specifics

CHAPTER 5 mikroPASCAL PRO for AVR Language Reference

CHAPTER 6 mikroPASCAL PRO for AVR Libraries



Table of Contents mikroPASCAL PRO for AVR

CHAPTER 1
Introduction to mikroPascal PRO forAVR ... ... ... ... .. .. ... ....... 1
Features . . .. ... 2
Whereto Start . ... . . . 3
mikroElektronika Associates License Statement and Limited Warranty 4
IMPORTANT - READ CAREFULLY .. ... ... . . i 4
LIMITED WARRANTY . . e e e 4
HIGH RISKACTIVITIES . ... e 5
GENERAL PROVISIONS . ... e e 6
Technical Support . ... .. . e 7
Howto Register . ... ... . . 8
Who Gets the License Key . ........ ... .. .. . . 8
After Receving the License Key .......... ... ... . ... . ... .... 10
NOteS: . 10
CHAPTER 2
IDE OVEIVIEW . . . . 12
Main Menu Options . . ... ... e 13
File Menu Options . ... ... ... .. . . i 14
EditMenu Options . ........ ... .. . 15
Find Text . ... . 16
Replace Text . ... .. 17
FindInFiles .. ... .. 17
GoToLine . ... 18
Regular expressions . .......... .. 18
View Menu Options . .......... i e 19
Toolbars ... . e 20
File Toolbar . ... ... . . . 20
Edit Toolbar . ... ... . . 20
Advanced Edit Toolbar . . ... . 21
Project Toolbar . . ... .. 22
Build Toolbar . ....... ... . . e 22
Debugger . ... 23
Styles Toolbar .. ... 23

vV MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD



mikroPASCAL PRO for AVR Table of Contents

Tools Toolbar . ... ... ... e 24
Project Menu Options . ... ... .. . 25
RunMenu Options . . ... ... e 27
Tools Menu Options . . ... ... e 29
Help Menu Option . ... . e e e 30
Keyboard Shortcuts . ... ... . . . 31
IDE OVEIVIEW . . .o e e 34
Customizing IDE Layout . ...... ... ... 36

Docking Windows . ... . ... .. 36

Saving Layout . .......... . ... 37

Auto Hide . . ... . e 38
Advanced Code Editor . .. ... ... ... . . .. 39

Advanced Editor Features . . .. ... ... . .. 39

Code Assistant . . ... . .. 40

Code Folding . ... i i 41

Parameter Assistant . ......... .. . . 42

Code Templates (Auto Complete) ......... .. ... .. .. . . ... 42

Auto Correct .. ... e 42

Spell Checker .. ... . . 43

Bookmarks . . ... 43

Goto Line .. ..o 43

Comment/Uncomment . ........... ... ... 43
Code EXplorer .. ... 44
Routine List . ... ... 45
Project Manager . ......... .. ... 46
Project Settings Window . ... ... ... . . . . . .. 48
Library Manager . . . ... o e e 49
Error Window . . ... e 51
Statistics .. ... 52

Memory Usage Windows . . .. ... . . 52
RAM MEMOrY . . . e 52
RX Memory Space ......... .. 52

Data Memory Space . ........... i 53

Special Function Registers . ........ .. ... ... . . L. 53

General Purpose Registers . ........ ... . . i i 54
ROM MemMOrY ..o e e 54

MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD \



Table of Contents mikroPASCAL PRO for AVR

ROMMemory Usage . ...t e 54
ROM Memory Allocation . ............ ... .. 55
Procedures Windows . . .. ... ... . 55
Procedures Size Window . .............. ... ... ... .. ... 55
Procedures Locations Window . ................ ... ... ........ 56
HTMLWindow . ... ... e 56
Integrated TooIs . . .. ... .. 57
USART Terminal .......... ... . . 57
ASCIIChart . ... 58
EEPROMEditor . . ... ... 59
7 Segment Display Decoder ............ ... ... 60
UDP Terminal . . ... ..o e e 61
Graphic Led Bitmap Editor ... .. ... 62
Lcd Custom Character .. ... ... .. . . 63
Macro Editor . ... .. 64
OptiONS . . . 65
Code editor ... ... . 65
TOOIS .o 65
Output settings .. ... 66
Regular EXpressions . ... ..ot 67
Introduction . ....... . . . 67
Simplematches . ......... .. ... .. . . .. 67
Escape sequences ... ........ ... 67
Characterclasses ....... ... i 68
Metacharacters ........ ... .. . . . . ... 68
Metacharacters - Line separators . ............................ 68
Metacharacters - Predefined classes .......................... 69
Metacharacters - Word boundaries . .......... ... .............. 69
Metacharacters - Iterators . . ............. ... .. . . ... ... .. 70
Metacharacters - Alternatives . ............... ... ... ......... 71
Metacharacters - Subexpressions .. ........................... 71
Metacharacters - Backreferences ............................. 71
mikroPascal PRO for AVR Command Line Options . ................... 72
Projects . ... 73
New Project . ... ... 73
New Project Wizard Steps . . ... ... 74

Vi MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD



mikroPASCAL PRO for AVR Table of Contents

Customizing Projects . . ... 77
Edit Project .. ... .. 77
Managing Project Group . ...... ... . .. 77
Add/Remove Files from Project . . .. ........ ... ... . ... ... 77
Project Level Defines . .. ... . 79

Source Files . .. .. 80
Managing Source Files . ........ ... . . . . 80
Creating new sourcefile ........ ... .. ... . . . . . . . ... 80
Opening an existing file .. ....... ... ... . . 80
Printinganopenfile ....... ... ... . . . . . . . .. 80
Savingfile ... ... . 81
Saving file under a differentname ............. ... ... .. ... .. .. 81
Closing file . . ... 81

Clean Project Folder .. ... . . . 82
Clean Project Folder . ... ... .. . . . . . . . . 82
Compilation . ......... . . . . . 83
Output Files . ... .. e 83
Assembly View . ... ... 83
Warning Messages: . ... ... e 85
Hint Messages: . ... e 85

Software Simulator Overview . ....... ... .. ... . .. 86
Watch Window . . . .. ... 86
Stopwatch Window . ....... ... . . . . 88
RAM WINdow . . ... . 89
Software Simulator Options . . ........... . ... . ... . .. 90

Creating New Library .. ... ... .. . . 91
Multiple Library Versions .. ... ... ... ... . . . . . 92
CHAPTER 3

Pascal Standard Issues .. ... . 94
Divergence from the Pascal Standard . . ........................ 94
Pascal Language Extensions ............ ... ... ... . ... .. ... .. 94

Predefined Globals and Constants ............. .. ... .. ... .. ... ..... 95
Math constants . ....... ... ... . . .. 95
Predefined project level defines .......... ... .. ... .. ... .. ..... 95

MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD VI



Table of Contents mikroPASCAL PRO for AVR

Accessing Individual Bits . .......... .. .. .. 96
Accessing Individual Bits Of Variables ......................... 96
Sbittype ... 96
bit type . . . 97

INterrupts . ... 98
Function Calls from Interrupt . . ............ ... .. ... ... ....... 98

Linker Directives . ......... . . 100
Directive absolute ........ ... ... .. .. . ... . 100
Directive Org ... ..o 101

Built-in Routines . . . . ... . 102
L0 o 102
Hi o 103
Higher ... 103
Highest . .. ... 103
INC 104
DeC . 104
Delay _Us . ... .. 104
Delay _MsS . ..o 105
Vdelay ms ... e 105
Delay_CyC ..o 105
Clock KHz . ... . . 106
Clock_MHz ... ... . 106
SetFuncCall . ... ... .. . 106

Code Optimization . . ... .. . 107
Constantfolding . . ... 107
Constant propagation ............. .. ... 107
Copy propagation . ............ ... 107
Value numbering . ........ ... . . . .. 107
"Dead code" ellimination ............... . ... ... . . . . . .. .. 107
Stack allocation . ......... . . ... 107
Local vars optimization ................ ... ... .. ... .. ... .. ... 107
Better code generation and local optimization ................... 107
Types Efficiency . ... e 109

Vil MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD



mikroPASCAL PRO for AVR Table of Contents

CHAPTER 4
Nested Calls Limitations . ............. ... ... .. .. ... ....... 110
Important notes: . . ... .. ... 110
AVR Memory Organization ............... ... .. 111
Program Memory (ROM) .. ....... ... .. . .. .. 1M1
Data Memory . . ... 112
Memory Type Specifiers .. ... . . 114
o7 o [ 114
data .. ... 114
G 114
o P 115
ST 115
FegiSter . o o 115
CHAPTER 5
mikroPascal PRO for AVR Language Reference ...................... 118
Lexical Elements Overview . ...... ... . . . . . . 120
Whitespace . ..... ... ... 120
Whitespace in Strings . ... . . 120
Nested comments . .......... .. i 121
TOoKENS . .. 122
Token Extraction Example .. ......... ... .. . i 122
Literals . ... . 123
Integer Literals . . .. ... .. 123
Floating Point Literals .. ...... ... ... ... ... .. .. . . ... ... 123
Character Literals . ......... .. . 124
String Literals . . . ... ... 124
Keywords . ... e 125
Identifiers ... ... . 126
Case Sensitivity .. ... 126
Uniqueness and SCOPE . . ...ttt e 126
Identifier Examples . ... ... . 126
Punctuators . ... ... .. 127
Brackets . . ... .. 127

MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD IX



Table of Contents mikroPASCAL PRO for AVR

Parentheses . . . ... . 127
ComMmMa .. 127
Semicolon . ... 128
Colon ... 128
DOt . 128
Program Organization ........ ... ... . . . . i 129
Organization of Main Unit . ......... .. ... . ... ... ... .. ... .... 129
Organization of Other Units . .. ...... ... .. ... .. ... .. ... . .... 130
Scope and Visibility ...... .. . . 132
SCOPE . . o 132
Visibility ... o 132
UNitS . e 133
Uses Clause . ...... ... e 133
Main Unit .. ... .. e 134
OtherUnits .. ... ... 134
Interface Section . ... .. ... . .. 134
Implementation Section . .......... ... ... .. 135
Variables . ... e 136
Variables and AVR . .. ... 136
Constants . . ... .. 137
Labels . ... 138
Functions and Procedures . . ... ... 139
Functions . ... . 139
Callingafunction . ... ... ... ... 139
Example . . ... 140
Procedures . ... .. . 140
Callingaprocedure ............. i 140
Example . . ... 141
Example: ... 141
Forward declaration . . ...... . ... ... ... .. . . ... 142
Ty PES o oot 143
Type Categories ... ... e 143
SIMple TYPES . ..t 144
ALY S o 145
Array Declaration . .. ... .. . 145
Constant Arrays . . ... 145

X MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD



mikroPASCAL PRO for AVR Table of Contents

Multi-dimensional Arrays . ... 146
SHriNGS . o 147
String Concatenating ........... ... ... 148
NOte . . 148
Pointers . ... 149
Function Pointers . . . . .. ... . 149
Example: . ... 149
@ Operator . ... .. 150
Records . ....... .. 151
Accessing Fields .. ... ... . 152
Types CONVEISIONS . .. .. e e 153
Implicit Conversion . ............ . . . . e 153
Promotion . ... . . . 153
ClippiNg ..o 153
Explicit Conversion . ... ... . . . .. 154
Conversions Examples . ............ ... 154
Operators . . . 155
Operators Precedence and Associativity ... ..................... 156
Arithmetic Operators . ......... .. . . 156
Division by Zero . .. ... . 157
Unary Arithmetic Operators . ........... .. ... . . . ... 157
Relational Operators .. .......... . ... .. ... . . ... 157
Relational Operators in Expressions . .......................... 157
Bitwise Operators . ...... ... . . . 158
Bitwise Operators Overview . ....... ... ... . . ... .. 158
Logical Operationson BitLevel ... ........... ... .. ........... 158
Unsigned and Conversions . ..............c..uiiiiiinnnen... 159
Signed and Conversions . .......... ... 159
Bitwise Shift Operators . ....... ... .. ... . ... . 160
Boolean Operators . ....... ... . . . 160
EXPressions . ... i 161
Statements . . . ... 162
Assignment Statements . . ....... ... 163
Compound Statements (Blocks) ........... ... .. ... .. ... .. ... 163
Conditional Statements ............ .. ... ... . ... 163
If Statement . ... ... . . 164

MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD Xl



Table of Contents mikroPASCAL PRO for AVR

Nestedifstatements ......... ... ... ... ... ... ... .. ... .. .... 164
Casestatement ........ ... ... ... . . .. 165
Nested Case statement . .......... ... ... ... ... ... ... ...... 166
lteration Statements . . ........ . 167
For Statement ...... ... .. .. .. . ... ... 168
Endless Loop . ... 168
While Statement . ........ .. . . . ... 169
Repeat Statement . ....... ... ... .. . .. 170
Jump Statements . .. ... 171
Break and Continue Statements . .......... ... ... ... ... ... .. 172
Break Statement . ...... ... .. .. .. ... 172
Continue Statement . .. ... ... .. ... . ... 172
Exit Statement . ........ ... 173
Goto Statement . ... .. 174
asm Statement . ... ... 175
Directives ... ... 176
Compiler Directives . ... ... .. ... . . 177
Directives $DEFINE and SUNDEFINE . ........................ 177
Directives $IFDEF..SELSE . ... ... ... ... .. . . .. 177
Include Directive $1 .. ... .. ... .. ... 178
Predefined Flags . ...... ... .. . 178
Linker Directives . ... ... 179
Directive absolute . ........ ... ... . . . . . . 179
Directive Oorg ... ... 179
CHAPTER 6
Hardware AVR-specific Libraries ... ........................... 182
Miscellaneous Libraries ... ........ ... .. ... . . .. 182
Library Dependencies . ... ....... ... 183
ADC Library . .. ... 185
ADC Read . ... ... . 185
HW Connection . ... ... ... .. . . i 186
External dependencies of CANSPI Library ...................... 187
Library Routines . ....... .. . 188
CANSPISetOperationMode .. ....... .. ... . . 188

Xl MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD



mikroPASCAL PRO for AVR Table of Contents

CANSPIGetOperationMode . . .............. ... 189
CANSPIInitialize . .......... .. 189
CANSPISetBaudRate ............ ... .. ... . . .. 191
CANSPISetMask . ...... ... 192
CANSPISetFilter . ... ... 193
CANSPIRead . . ... 194
CANSPIWTrite . ... 195
CANSPIConstants ... ... ... e 195
CANSPI_OP_MODE . ... . e 196
CANSPI_CONFIG_FLAGS . ... . e 196
CANSPI_TX_MSG FLAGS . ... .. . e 197
CANSPI_RX_MSG_FLAGS ... ... . i 197
CANSPI MASK . . 198
CANSPI_FILTER . ..o e e e 198
Library Example . . . ... ... 198
HW Connection . ......... .. e e 202
Compact Flash Library . ......... .. .. i 203
External dependencies of Compact Flash Library ................ 204
Library Routines . ... ... . 205
Cf NIt .. 205
Cf Detect . ... 207
CfEnable . ....... .. 207
Cf Disable . ... ... .. 207
Cf Read Init . ... ... . 208
Cf Read Byte ...... ... .. 208
Cf Write_Init .. ... .. . 209
Cf Write Byte . ........ . e 209
Cf Read_Sector ........ ... .. i i 210
Cf_Write_Sector . ........ .. 210
Cf Fat Init . ... . 211
Cf_Fat QuickFormat . ... ... .. ... ... .. ... 211
Cf Fat _ASSIgN ... 212
Cf Fat Reset.......... .. 213
Cf Fat Read ........ ... .. i 213
Cf_Fat_ Rewrite ...... ... . . 214
Cf_Fat_ Append . ... ... . . . e 214

MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD Xl



Table of Contents mikroPASCAL PRO for AVR

Cf Fat Delete ......... .. e 214
Cf Fat_ Write . ... . 215
Cf_Fat_Set_File Date .. ... ... .. .. i 216
Cf Fat Get File Date . ....... ... .. . . ... . . . 217
Cf Fat Get File Size ......... ... . . . . . .. 217
Cf Fat Get Swap File ...... ... ... ... . . ... . . . 218
HW Connection . ... ... ... . . e 226
EEPROM Library .. ... ... e e e 227
Library Routines . ... ... 227
EEPROM Read . ...... ... . . e 227
EEPROM_Write . . ... e e 228
Library Example . . ... ... 228
Flash Memory Library .. ... .. .. 230
Library Routines . ... ... . 230
FLASH Read Byte ......... ... . . i 230
FLASH_Read Bytes ....... ... . i 231
FLASH_Read_Word . ...... ... . .. e 231
FLASH_Read_Words .......... . .. i 232
Library Example . . . ... 232
Graphic Led Library .. .. 234
External dependencies of Graphic Led Library .. ................. 234
Library Routines . ....... .. ... . 235
Gled_Init . .. 236
Gled_Set_Side .. ... .o 237
Gled_Set X ..o 237
Gled_Set_ Page ... 238
Gled Read Data ........ ... ... ... . . .. 238
Gled Write Data ........... .. .. . 239
Gled _Fill .o 239
Gled Dot .. 240
Gled_Line ..o 240
Gled_V _Line ... 241
Gled_H_Line ... 241
Gled_Rectangle . ... ... 242
GICd BOX .\ttt 242
Gled_Circle ... ... 243

XV MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD



mikroPASCAL PRO for AVR Table of Contents

Gled Set Font . ........ .. . 243
Gled_Write_Char . ... . . 244
Gled_Write_Text . ... . 245
Gled_Image . ... 245
Library Example . . . .. ... 246
HW Connection . ........ .. e 248
Keypad Library . ... ... 249
External dependencies of Keypad Library . . ..................... 249
Library Routines . ... ... 249
Keypad_Init ... ... .. . 249
Keypad Key Press ........ .. i 250
Keypad Key Click . ..... ... ... . . . . .. 250
Library Example . . . ... . 250
HW Connection .. ... ... . . . e 253
External dependencies of Lcd Library .. .......... ... ... ... .. 254
Library Routines . ... ... .. . . . 254
Led Init ..o 255
Led _Out ..o 256
Led _Out Cp .o 256
Led _Chr .. 257
Led Chr Cp ..o 257
Led Cmd ..o 258
Available Led Commands ............ ... . i 258
Library Example . . . ... 259
HW connection .. ... .. ... . ... . . 261
Manchester Code Library . ...... ... .. . . . . . . 262
External dependencies of Manchester Code Library .............. 262
Library Routines . ........ . .. 263
Man_Receive_Init . ... . . . 263
Man_Receive . . ... . . 264
Man _Send Init........ ... . . . . . 264
Man_Send . ........ .. 265
Man_Synchro . ....... ... 265
Man_Break ....... ... .. . 266
Library Example . . . ... 267
Connection Example . ... ... .. .. . . . . 269

MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD XV



Table of Contents mikroPASCAL PRO for AVR

Multi Media Card Library . ........... ... . . 271
Secure Digital Card . ......... ... . 271
External dependencies of MMC Library ........................ 271
Library Routines . ... ... 272
Mmc Init ... .. 273
Mmc _Read Sector ........ ... ... . . . . . . 274
Mmc_Write_Sector . ..... ... . . . . . 274
Mmc_Read_Cid . ... .. 275
Mmc_Read Csd ....... ... ... 275
Mmc Fat Init ... .. 276
Mmc_Fat_QuickFormat . .......... ... ... ... . . . 277
Mmc_Fat Assign ........ .. 278
Mmc_Fat Reset ........ ... . . . . 279
Mmc Fat Read ...... ... ... .. . . . . 279
Mmc Fat Rewrite ....... .. ... . ... . . . . . . 280
Mmc_Fat Append . ... .. .. . . 280
Mmc_Fat Delete ........ .. ... . . 280
Mmc_Fat Write . ... ... . 281
Mmc_Fat_Set File Date . ...... ... ... .. . i, 282
Mmc_Fat Get File Date .. .............. ... ... .. ... ... ...... 283
Mmc_Fat Get File Size .......... ... ... ... . . . . . . ... 283
Mmc_Fat Get Swap File .............. ... ... ... ... .. ....... 284
Library Example . . . .. ... 286
HW Connection . ... ... . . . . e 294

OneWire Library . .. ... 295
External dependencies of OneWire Library . ..................... 295
Library Routines . ....... .. .. 295
Ow _Reset ... .. 296
Ow_Read .. ... 297
Ow _Write . ... 298
Library Example . . . ... ... 298
HW Connection . .......... . e e 301
Port Expander Library ......... ... ... . . . . . . 302
External dependencies of Port Expander Library ................. 302
Library Routines . ... .. . 302
Expander Init. ... ... ... 303

XVI MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD



mikroPASCAL PRO for AVR Table of Contents

Expander Read Byte ....... ... ... ... . . . . . ... 304
Expander_ Write_ Byte ......... ... . ... .. 304
Expander_Read_PortA .. ... .. . . . 305
Expander Read PortB ...... ... ... .. ... . ... . ... ... 305
Expander Read PortAB . ... ... ... .. . . . ... 306
Expander Write_ PortA . ... ... ... . ... . 306
Expander_ Write_ PortB . ....... ... .. ... .. 307
Expander_Write_PortAB . .. ... ... . ... .. 308
Expander_Set DirectionPortA . .. ... . ... ... 308
Expander_Set DirectionPortB . .. ......... ... ... . ... ... 309
Expander_Set DirectionPortAB . ......... ... ... .. ... .. ... .. 309
Expander_Set PullUpsPortA .. ...... ... ... ... ... ... ... ....... 310
Expander_Set_PullUpsPortB . .. ....... ... ... ... . . 310
Expander_Set PullUpsPortAB ........ ... ... ... . ... ....... 311
Library Example . . . ... ... 311
HW Connection . ......... .. e e 313
Port Expander HW connection .. ............................. 313
PS/2 Library .. ... 314
External dependencies of PS/2 Library . .. .......... ... .. ... ... 314
Library Routines . ... ... 314
Ps2_Config . ... 315
Ps2_ Key Read ......... .. 316
Special Function Keys . ... ... . . 317
Library Example . . . ... 318
HW Connection .. ... . ... . 319
PWM Library . ... .. 320
Library Routines . ........ . ... . 320
Predefined constants used in PWMlibrary ...................... 320
PWM Init ... e 323
PWM _Set Duty ...... ... e e 324
PWM_Start . ... e 324
PWM _StOp . . oo 325
PWM1_Init ..o 325
PWM1 Set Duty ... e e 327
PWM1 _Start . ... e 327
PWMI StOp . . o 327

MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD ~ XVII



Table of Contents mikroPASCAL PRO for AVR

Library Example . . ... ... 328
HW Connection . ... .. .. . 329
PWM 16 bit Library .. ......... . 330
Library Routines . ... ... 330
Predefined constants used in PWM-16bit library ................. 330
PWM16bit_Init .. ... 332
PWM16bit_Change Duty ........... ... .. ... . . ... 334
PWM16bit_Start ... ... . . 334
PWM16bit_Stop . .. ... 335
Library Example . . . ... ... 335
HW Connection . ........ .. . e 337
RS-485 Library . .. ... 338
External dependencies of RS-485 Library . . ..................... 339
Library Routines . ... ... . 339
RS485Master Init . ...... .. .. .. ... 340
RS485Master Receive ........... ... ... . . . i 341
RS485Master Send . ........... . . ... ... 342
RS485Slave_Init . ...... ... . . . 343
RS485slave_Receive . ........ . .. . 344
RS485Slave_Send . ......... .. ... 344
Library Example . . . ... ... e 345
HW Connection . ........ .. e 349
Message format and CRC calculations . ........................ 350
Software [ C Library . . ... .. . 351
External dependencies of Soft [2C Library ... ................... 351
Soft_12C_Init ... .. 352
Soft 12C_Start . ... ... 353
Soft 12C_ Read .......... . .. 353
Soft_12C_Write . ... ... 354
Soft_12C_Stop .. ... 354
Soft 12C Break . ....... ... .. . ... 355
Library Example . . . ... ... 356
Software SPI Library .. ... . . . . 359
External dependencies of Software SPI Library .................. 359
Soft_ SPI_Init ... ... . 360
Soft SPI_Read ......... .. .. .. 361

XVIIl MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD



mikroPASCAL PRO for AVR Table of Contents

Soft SPIL Write . ... . . . 361
Library Example . . . ... . 362
Software UART Library . ... .. 364
External dependencies of Software UART Library ................ 364
Soft UART _Init . ... . 365
Soft UART_Read ............ i 366
Soft UART_Write . ... .. .. 367
Soft UART _Break ....... ... .. .. 368
Library Example . . . ... 369
Sound Library . ... .. 370
External dependencies of Sound Library ....................... 370
Library Routines . ....... .. .. 370
Sound_Init ... 370
Sound_Play . ... 371
Library Example . . . ... ... 371
HW Connection . ......... .. e e 373
SPILibrary ... 374
SPI NIt .. 374
SPIM_Init_Advanced ........ ... .. ... ... 375
SPIT_Read . ... ... 376
SPI _Write . . . 376
Library Example . . ... ... 377
HW Connection . ... ... ... . . e 379
SPI Ethernet Library .. ... . .. . 380
External dependencies of SPI Ethernet Library . ................. 381
Library Routines . ... ... .. . . . . 382
Spi_ Ethernet Init . ........ .. ... .. . . . 382
Spi_Ethernet Enable . . ..... ... .. ... . . ... 383
Spi_Ethernet_Disable ......... ... ... ... .. 385
Spi_Ethernet_doPacket .. ... ... ... ... ... 386
Spi_Ethernet_putByte . ..... ... ... . ... 387
Spi_Ethernet_putBytes ...... ... ... ... .. 387
Spi_Ethernet putConstBytes .. ............. ... ... ... . ....... 388
Spi_Ethernet_putString ........ ... ... 388
Spi_Ethernet_putConstString . ...... ... . ... ... . L. 389
Spi_Ethernet_getByte . ... ... .. ... 389

MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD XIX



Table of Contents mikroPASCAL PRO for AVR

Spi_Ethernet getBytes ........ ... ... . . ... 390
Spi_Ethernet_UserTCP . ... ... ... .. . . . . . . 390
Spi_Ethernet_UserUDP .. ... ... .. .. . . . . i 391
Library Example . . . ... 391
HW Connection . ... ... . . e e 400
SPI Graphic Led Library . ... ... . . 401
External dependencies of SPI Graphic Led Library . .............. 401
Library Routines . ... .. . 401
SPI_Gled_Init . .. .. 402
SPI_Gled_Set_Side . . ... ... 403
SPI Glecd _Set Page ........ ... i 403
SPI_Gled_Set_X ... . 404
SPI_Glcd_Read Data ........... ... . . . i 404
SPI_Gled Write Data ....... ... .. .. . . . . 405
SPI_Gled_Fill . ... 405
SPI_Gled_Dot ... 406
SPI_Gled_Line . . ... 406
SPIL_Glcd_V_Line ... ... 407
SPI_Glcd_H_Line ... . . 407
SPI_Gled_Rectangle . ....... ... .. . .. . 408
SPI_GICA_BOX ..ot 408
SPIL Glcd _Circle ... 409
SPIL_Gled_Set_Font . ... .. 409
SPI_Gled_Write_Char ....... ... .. .. 410
SPI_Gled Write_Text . .. ... ... 411
SPLGlcd_Image ... 411
Library Example . . ... ... 412
HW Connection . ... ... e 414
SPlLed Library . ... 415
External dependencies of SPI Led Library . ..................... 415
Library Routines . ... ... .. . . . . 415
SPlLLed _Config ... vvv i 416
SPI_Led_Out ... 417
SPI_Lcd_Out Cp . .ooi e 417
SPI_Led_Chr ... 418
SPI_Lcd_Chr_Cp ... oo 418

XX MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD



mikroPASCAL PRO for AVR Table of Contents

SPlLLed _Cmd ... 419
Available SPI Led Commands . .......... ... ... ... 419
Library Example . . . ... 420
HW Connection .. ... ... .. . 421
SPI Lcd8 (8-bitinterface) Library . ... ... ... 422
External dependencies of SPI Lcd Library ...................... 422
Library Routines . ... ... . . . 422
SPlL Led8 Config ... oo oo 423
SPlL Lcd8 Out ... 424
SPlLLcd8 Out Cp.ovvi e 424
SPlL Led8 Chr ..o 425
SPlLLed8 Chr Cp ..o 425
SPlL Led8 Cmd ... 426
Available SPI Lcd8 Commands .............. ... ... .. .. ..... 426
Library Example . . . ... ... 427
HW Connection . ......... .. e e 428
SPI T6963C Graphic Led Library . .............. ... .. .. ....... 429
External dependencies of SPI T6963C Graphic Lcd Library ........ 429
Library Routines . ... ... . 430
SPIL_TB963C_Config . ...... ..o e 431
SPI_T6963C _WriteData ........... .. ... ... ... . .. 432
SPI_T6963C WriteCommand ................... ... ......... 433
SPI_TB963C _SetPtr ....... ... . 433
SPI_T6963C WaitReady . ............ ...t 433
SPILTB963C _Fill .. ... . 434
SPILTB963C Dot . ... . 434
SPI_T6963C_Write_Char .......... ... ..., 435
SPI_T6963C_Write_Text . ........ ... i 436
SPILT6963C Line . ... ... 437
SPI_T6963C Rectangle .............. . .. ... ... 437
SPILTB963C BOX . ..o it 438
SPILTB963C_Circle .. ... e 438
SPILT6963C_Image . ..........iiii i 439
SPILTB963C _Sprite . . ... 439
SPI_TB963C_Set_Cursor ........ ...t 440
SPI_T6963C ClearBit ........... ... ... .. 440

MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD XXI



Table of Contents mikroPASCAL PRO for AVR

SPI_T6963C_SetBit. . ...... .. 440
SPI_TE963C_NegBit ... ... ... .. . 441
SPI_T6963C_DisplayGrPanel ............. ... .. ... .. ... . .... 441
SPI_T6963C_DisplayTxtPanel .......... ... .. ... ... ........ 441
SPI_T6963C SetGrPanel .......... ... ... ... .. ... ...... 442
SPI_T6963C_SetTxtPanel .. ......... .. ... ... . . . ... 442
SPI_T6963C_PanelFill . ...... ... ... .. . . . 442
SPI_TE963C_GrFill ... ... . 443
SPI_TE963C_TxtFill . . ... ... 443
SPI_T6963C_Cursor_Height .............. ... .. ... .. ........ 443
SPI_T6963C Graphics ......... ...t 444
SPILTB963C_Text . ... e 444
SPI_TB963C_CUrsor . . ...t e 444
SPI_T6963C _Cursor Blink . ........... . .. ... ... . . . ... 445
Library Example . . . ... ... 445
HW Connection . ......... .. e e 450
T6963C Graphic Led Library .. ... ... 451
External dependencies of T6963C Graphic Lcd Library ............ 452
Library Routines . ... ... . 453
TEI63C_Init . . ... 454
T6963C_WriteData . ........... . 456
T6963C_WriteCommand .. ........... .. i 456
TE963C_SetPtr .. ... 456
T6963C_WaitReady ........ ... .. .. .. 457
TEI63C_Fill ... 457
TB963C Dot . ..o e 457
T6963C_Write_Char ... ... .. 458
T6963C_Write_Text ... ... . 459
TBI63C_Line . ..o 460
T6963C_Rectangle . ... ... .. . 460
TBOB3C _BOX ..t vttt e 461
T6963C_Circle . . ... 461
T6I63C IMage .. ..ot e 462
TBO63C_Sprite . . . .ot 462
TB963C_Set CUursor . ...t e 463
T6963C DisplayGrPanel .. ... .. ... .. .. . . . .. . 463

XXI MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD



mikroPASCAL PRO for AVR Table of Contents

T6963C DisplayTxtPanel .......... ... ... .. ... ... .. .. . ... 463
T6963C_SetGrPanel . ... .. .. . . . 464
T6963C_SetTxtPanel ....... ... . . . .. . . 464
T6963C_PanelFill ........... .. . . 464
T6963C_GrFill . ... 465
T6963C_TxtFill . ... e 465
T6963C_Cursor_Height . .. ... .. .. .. 465
T6963C_GraphiCs ... ... 466
TBOB3C _TexXt ..ot e 466
TBIB3C CUISOr . . ot e e e e 466
T6963C Cursor Blink . ............ ... . ... . . . i 467
Library Example . . ... ... 467
HW Connection . ... ... . . . e 472
T6963C Glcd HW connection . ........ .. ... .. ... ... .. ... .... 472
Library Routines . ... ... .. . . . . . 473
TWEINit . 473
TWI_BUSY .. 473
TWI Start . .. 474
TWI_Read . ... e 474
TWIWrite .. 474
TWE S 0P . o oo 475
TWI_Status . ... 475
TWI_CIOSE . . .t 475
Library Example . . . ... 476
HW Connection .. ... . ... . 476
UART Library .. ... . 477
Library Routines . ........ . ... . 477
UARTX_INit .. 478
UARTx_Init_Advanced .......... ... ... .. 479
UARTx Data Ready .......... .. .. ... . .. 479
UARTX Read ... ... e e e 480
UARTXx Read Text ........ ... . . 480
UARTX_Write . ..o e e e 481
UARTXx Write_ Text . .......... .. i 481
Library Example . . . ... 482
HW Conection . ... ... ... . 483

MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD XXl



Table of Contents mikroPASCAL PRO for AVR

Button Library . ... . 484
External dependencies of Button Library . ...................... 484
Library Routines . ... . . 484
Button .. ... 484
Conversions Library . . ... 486
Library Routines . ....... .. .. . 486
ByteToStr . ... 486
ShortToStr . ... 487
WordToStr .. ... e 487
IN oSt .. 488
LongintToStr . . ... ... e 488
LongWordToStr . ... ... e 489
FloatToStr . ... .. 490
Dec2Bcd .. ... 490
Bcd2DeCT6 . ... 491
DeC2BCdlB ... e 491

Math Library . ... . 492
Library Functions . . ... ... 492
AC0S . o it 492
ASIN L 492
atan .. 493
atan? .. 493
CeIl Lo 493
0 o ittt 493
COSh . . 493
eval_poly ... 493
EXD + ot e e 493
fabs .. 494
XD . o 494
0 = 494
oo 494
o T 494
MO . 494
POW ottt 494
SN L 495
SiNh . 495

XXV MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD



mikroPASCAL PRO for AVR Table of Contents

SOM . o 495
AN e 495
anh e 495
String Library . .. ... 496
Library Functions . . ... . . 496
MeMChr . e 496
0 T=T 30 o7 0T o T 497
MEMCPY . o o et et e e e e e e e e 497
MEMIMOVE . . . ottt e e e et e e e e e ettt 497
Mmemsel . . ... 498
Streat ... 498
SICNr 498
S M .. 498
I CPY . . 499
SUCSPN L . 499
Strlen ... 499
strncat ... .. 499
SHINCMID .. 499
UMDY . oo 500
Strpbrk .. 500
strrchr . .. 500
SUSPN . . 500
SISt L 500
Time Library . . ... e 501
Library Routines . ... .. . 501
Time_dateToEpoch .. ... ... .. . . ... . . . . . . . 501
Time_epochToDate ........ ... ... .. .. . . . . . . 502
Time_dateDiff . . ... ... e 502
Library Example . . ... ... 503
TimeStruct type definition . ...... .. .. ... . . . 503
Trigonometry Library .. ... . . . 504
Library Routines . ... ... .. . . . . . . 504
SINES .. 504
COSES . .o 505

MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD XXV



Table of Contents mikroPASCAL PRO for AVR

XXVI MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD



CHAPTER _

Introduction to
mikroPascal PRO for AVR

Help version: 2009/05/18

The mikroPascal PRO for AVR is a powerful, feature-rich development tool for
AVR microcontrollers. It is designed to provide the programmer with the easiest
possible solution to developing applications for embedded systems, without com-
promising performance or control.
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Introduction to mikroPascal PRO for AVR
Features

- mikroPascal PRO for AVR allows you to quickly develop and deploy complex
applications:

- Write your Pascal source code using the built-in Code Editor (Code and Parame-
ter Assistants, Code Folding, Syntax Highlighting, Auto Correct, Code Templates,
and more.)

- Use included mikroPascal PRO for AVR libraries to dramatically speed up the
development: data acquisition, memory, displays, conversions, communication etc.

- Monitor your program structure, variables, and functions in the Code Explorer.

- Generate commented, human-readable assembly, and standard HEX compatible
with all programmers.

- Inspect program flow and debug executable logic with the integrated Software
Simulator.

- Get detailed reports and graphs: RAM and ROM map, code statistics, assembly
listing, calling tree, and more.

- mikroPascal PRO for AVR provides plenty of examples to expand, develop, and
use as building bricks in your projects. Copy them entirely if you deem fit — that’s
why we included them with the compiler.

2
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Where to Start

- In case that you're a beginner in programming AVR microcontrollers, read careful
ly the AVR Specifics chapter. It might give you some useful pointers on AVR con
straints, code portability, and good programming practices.

- If you are experienced in Pascal programming, you will probably want to consult
mikroPascal PRO for AVR Specifics first. For language issues, you can always
refer to the comprehensive Language Reference. A complete list of included
libraries is available at mikroPascal PRO for AVR Libraries.

- If you are not very experienced in Pascal programming, don’t panic! mikroPascal
PRO for AVR provides plenty of examples making it easy for you to go quickly. We
suggest that you first consult Projects and Source Files, and then start browsing
the examples that you're the most interested in.
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MIKROELEKTRONIKA ASSOCIATES LICENSE STATEMENT AND
LIMITED WARRANTY

IMPORTANT - READ CAREFULLY

This license statement and limited warranty constitute a legal agreement (“License Agree-
ment”) between you (either as an individual or a single entity) and mikroElektronika
(“mikroElektronika Associates”) for software product (“Software”) identified above, includ-
ing any software, media, and accompanying on-line or printed documentation.

BY INSTALLING, COPYING, OR OTHERWISE USING SOFTWARE, YOU AGREE TO
BE BOUND BY ALL TERMS AND CONDITIONS OF THE LICENSE AGREEMENT.

Upon your acceptance of the terms and conditions of the License Agreement, mikroElek-
tronika Associates grants you the right to use Software in a way provided below.

This Software is owned by mikroElektronika Associates and is protected by copy-
right law and international copyright treaty. Therefore, you must treat this Software
like any other copyright material (e.g., a book).

You may transfer Software and documentation on a permanent basis provided. You
retain no copies and the recipient agrees to the terms of the License Agreement.
Except as provided in the License Agreement, you may not transfer, rent, lease,
lend, copy, modify, translate, sublicense, time-share or electronically transmit or
receive Software, media or documentation. You acknowledge that Software in the
source code form remains a confidential trade secret of mikroElektronika Associates
and therefore you agree not to modify Software or attempt to reverse engineer,
decompile, or disassemble it, except and only to the extent that such activity is
expressly permitted by applicable law notwithstanding this limitation.

If you have purchased an upgrade version of Software, it constitutes a single prod-
uct with the mikroElektronika Associates software that you upgraded. You may use
the upgrade version of Software only in accordance with the License Agreement.

LIMITED WARRANTY

Respectfully excepting the Redistributables, which are provided “as is”, without war-
ranty of any kind, mikroElektronika Associates warrants that Software, once updat-
ed and properly used, will perform substantially in accordance with the accompany-
ing documentation, and Software media will be free from defects in materials and
workmanship, for a period of ninety (90) days from the date of receipt. Any implied
warranties on Software are limited to ninety (90) days.

mikroElektronika Associates’ and its suppliers’ entire liability and your exclusive
remedy shall be, at mikroElektronika Associates’ option, either (a) return of
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of the price paid, or (b) repair or replacement of Software that does not meet
mikroElektronika Associates’ Limited Warranty and which is returned to mikroElek-
tronika Associates with a copy of your receipt. DO NOT RETURN ANY PRODUCT
UNTIL YOU HAVE CALLED MIKROELEKTRONIKA ASSOCIATES FIRST AND
OBTAINED A RETURN AUTHORIZATION NUMBER. This Limited Warranty is void
if failure of Software has resulted from an accident, abuse, or misapplication. Any
replacement of Software will be warranted for the rest of the original warranty peri-
od or thirty (30) days, whichever is longer.

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW,
MIKROELEKTRONIKA ASSOCIATES AND ITS SUPPLIERS DISCLAIM ALL
OTHER WARRANTIES AND CONDITIONS, EITHER EXPRESSED OR IMPLIED,
INCLUDED, BUT NOT LIMITED TO IMPLIED WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE, AND
NON-INFRINGEMENT, WITH REGARD TO SOFTWARE, AND THE PROVISION
OF OR FAILURE TO PROVIDE SUPPORT SERVICES.

IN NO EVENT SHALL MIKROELEKTRONIKA ASSOCIATES OR ITS SUPPLIERS BE
LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT, OR CONSEQUENTIAL
DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR
LOSS OF BUSINESS PROFITS AND BUSINESS INFORMATION, BUSINESS
INTERRUPTION, OR ANY OTHER PECUNIARY LOSS) ARISING OUT OF THE USE
OF OR INABILITY TO USE SOFTWARE PRODUCT OR THE PROVISION OF OR
FAILURE TO PROVIDE SUPPORT SERVICES, EVEN IF MIKROELEKTRONIKA
ASSOCIATES HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. IN
ANY CASE, MIKROELEKTRONIKA ASSOCIATES’ ENTIRE LIABILITY UNDER ANY
PROVISION OF THIS LICENSE AGREEMENT SHALL BE LIMITED TO THE AMOUNT
ACTUALLY PAID BY YOU FOR SOFTWARE PRODUCT PROVIDED, HOWEVER, IF
YOU HAVE ENTERED INTO A MIKROELEKTRONIKA ASSOCIATES SUPPORT
SERVICES AGREEMENT, MIKROELEKTRONIKA ASSOCIATES’ ENTIRE LIABILITY
REGARDING SUPPORT SERVICES SHALL BE GOVERNED BY THE TERMS OF
THAT AGREEMENT.

HIGH RISK ACTIVITIES

Software is not fault-tolerant and is not designed, manufactured or intended for use
or resale as on-line control equipment in hazardous environments requiring fail-safe
performance, such as in the operation of nuclear facilities, aircraft navigation or
communication systems, air traffic control, direct life support machines, or weapons
systems, in which the failure of Software could lead directly to death, personal injury,
or severe physical or environmental damage (“High Risk Activities”). mikroElektron-
ika Associates and its suppliers specifically disclaim any expressed or implied war-
ranty of fitness for High Risk Activities.
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GENERAL PROVISIONS

This statement may only be modified in writing signed by you and an authorised offi-
cer of mikroElektronika Associates. If any provision of this statement is found void
or unenforceable, the remainder will remain valid and enforceable according to its
terms. If any remedy provided is determined to have failed for its essential purpose,
all limitations of liability and exclusions of damages set forth in the Limited Warran-
ty shall remain in effect.

This statement gives you specific legal rights; you may have others, which vary, from
country to country. mikroElektronika Associates reserves all rights not specifically
granted in this statement.

mikroElektronika
Visegradska 1A,
11000 Belgrade,
Europe.

Phone: + 381 11 36 28 830
Fax: +381 11 36 28 831
Web: www.mikroe.com
E-mail: office@mikroe.com
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TECHNICAL SUPPORT

In case you encounter any problem, you are welcome to our support forums at
www.mikroe.com/forum/. Here, you may also find helpful information, hardware tips,
and practical code snippets. Your comments and suggestions on future develop-
ment of the mikroPascal PRO for AVR are always appreciated — feel free to drop a
note or two on our Wishlist.

In our Knowledge Base www.mikroe.com/en/kb/ you can find the answers to Fre-
quently Asked Questions and solutions to known problems. If you can not find the
solution to your problem in Knowledge Base then report it to Support Desk
www.mikroe.com/en/support/. In this way, we can record and track down bugs more
efficiently, which is in our mutual interest. We respond to every bug report and ques-
tion in a suitable manner, ever improving our technical support.
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HOW TO REGISTER

The latest version of the mikroPascal PRO for AVR is always available for download-
ing from our website. It is a fully functional software libraries, examples, and com-
prehensive help included.

The only limitation of the free version is that it cannot generate hex output over 2
KB. Although it might sound restrictive, this margin allows you to develop practical,
working applications with no thinking of demo limit. If you intend to develop really
complex projects in the mikroPascal PRO for AVR, then you should consider the
possibility of purchasing the license key.

Who Gets the License Key

Buyers of the mikroPascal PRO for AVR are entitled to the license key. After you
have completed the payment procedure, you have an option of registering your
mikroPascal. In this way you can generate hex output without any limitations.

How to Get License Key

After you have completed the payment procedure, start the program. Select Help »
How to Register from the drop-down menu or click the How To Register Icon | ..
Fill out the registration form (figure below), select your distributor, and click the Send
button.
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mHowToRegister El [=] @

step 1. Fill in the form below. Please, make sure you fill in all required fields.
Step 2. Make sure that you provided a walid email address in the "EMAIL" edit baox. This email will be used far

sending yvou the activation key,

Step 3. Make sure you select a correct distributar which will rmake the registration process faster. If your
distributor is not on the list then select "Other” and type in distributor's email address in the box below,

Step 4. Press the SEMD button to send key request. A default email client will open with ready-to-send message.
Mote: If email client does not open, you may copy text of the message and paste it manually into a new email
message before sending it to vour distributar's email,

IW Marko Jovanovic
IW Enker your address

INVOICE Enter inwaice number if available
IW rnarko@miky o, com
IW rnarko@miky o, com
IW Enker company name
|| PRODUCTID | 515C-557265-6FED72-664F
[DISTRIBUTORY

* Required fields

I have made the payment and I wish to request activation keyv for mikroPascal PRO for AYVR

Name:
Marko Jovanovic

Address:
Invoice number:
Company:
E-Mail:

rnatko@mikyoe, com

Product key:
515C-557269-6Fa0 7 2-054F

Distributor:
2o Copyto [ SEND Cancel
= dipboard

This will start your e-mail client with message ready for sending. Review the information you
have entered, and add the comment if you deem it necessary. Please, do not modify the sub-
ject line.

Upon receiving and verifying your request, we will send the license key to the e-mail address
you specified in the form.
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After Receving the License Key

The license key comes as a small autoextracting file — just start it anywhere on your
computer in order to activate your copy of compiler and remove the demo limit. You
do not need to restart your computer or install any additional components. Also,
there is no need to run the mikroPascal PRO for AVR at the time of activation.

Notes:

- The license key is valid until you format your hard disk. In case you need to format
the hard disk, you should request a new activation key.

- Please keep the activation program in a safe place. Every time you upgrade the
compiler you should start this program again in order to reactivate the license.
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IDE OVERVIEW

The mikroPascal PRO for AVR is an user-friendly and intuitive environment:
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N Insert ChmikroPascal PRO for AVR\E

- The Code Editor features adjustable Syntax Highlighting, Code Folding, Code
Assistant, Parameters Assistant, Spell Checker, Auto Correct for common typos
and Code Templates (Auto Complete).

- The Code Explorer (with Keyboard shortcut browser and Quick Help browser) is at
your disposal for easier project management.

- The Project Manager alows multiple project management

- General project settings can be made in the Project Settings window

- Library manager enables simple handling libraries being used in a project

- The Error Window displays all errors detected during compiling and linking.

- The source-level Software Simulator lets you debug executable logic step-by-step
by watching the program flow.

- The New Project Wizard is a fast, reliable, and easy way to create a project.

- Help files are syntax and context sensitive.

- Like in any modern Windows application, you may customize the layout of mikroPascal
PRO for AVR to suit your needs best.
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- Spell checker underlines identifiers which are unknown to the project. In this way
it helps the programmer to spot potential problems early, much before the project
is compiled.

- Spell checker can be disabled by choosing the option in the Preferences dialog (F12).

MAIN MENU OPTIONS

Available Main Menu options are:

File

Edit

Wigy

Project

Bun

Tools

Help

Related topics: Keyboard shortcuts
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File Menu Options

The File menu is the main entry point for manipulation with the source files.

L] Mew Unit  Crl+N
2 Open Chrl4
Recent Files k
H save Chr+5
Fﬁ Save fs
»u Close Ctrl+F4
= Print..  Ctr4+P
B Ext Akt
File Description
'] Mewlnit ctrl+M |[[Open a new editor window.
,ﬁ Open Ctri+2 | Open source file for editing or image file for viewing.
Recent Files * | Reopen recently used file.
H save Ctri+3 | Save changes for active editor.

Save the active source file with the different name or

H Save bs change the file type.

Ll Close al+F4 || Close active source file.
s Prink... Ckrl+P | Print Preview.

B Exit Ale+x | Exit IDE.

Related topics: Keyboard shortcuts, File Toolbar, Managing Source Files
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Edit Menu Options

<3 Undo Chrl+2
| Redo Shift+Chrl+2
gy Cut Chrl+
E= Copy Chrl+C
[ Paste Chriy
X Delete

Select al Chrl+A
A Find... Chrl+F
el Find Hext F3
93 Find Previous  Shift+F3
)R Replace. .. Ctrl+R
|d] FindInFiles...  Alt+F3
+ ] Goto Line... Tt

Advanced r

File Description

<& Undo Ctrl+Z |Undo last change.
& Redo shift+Ckrl+2 | Redo last change.
gb Cut i+ | Cut selected text to clipboard.
=2 Copy Ctri+Z | Copy selected text to clipboard.
I Paste Ctrl+y | Paste text from clipboard.
> Delete Delete selected text.

Select Al Ctrl+a | Select all text in active editor.
A2 Find... trl+F |Find text in active editor.
_)3 Find Mesxt F3 |Find next occurence of text in active editor.
‘}-J Find Previous  Shift+F3 |Find previous occurence of text in active editor.
M Replace... Ctr+r |Replace text in active editor.

MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD

15



CHAPTER 2
Environment mikroPASCAL PRO for AVR

Find text in current file, in all opened files, or in files

[ FindInFies..  Al+F3 from desired folder.

¢-_:] Goko Line. .. Cr+5 | Goto to the desired line in active editor.
Advanced k| Advanced Code Editor options
Advanced » Description

Comment selected code or put single line com-

L) Cemmens S Cy ment if there is no selection.

Uncomment selected code or remove single line

N comment if there is no selection.

%=  [Indent shift+Ctr+I | Indent selected code.

=% Outdent shift+Ctr4+U | Outdent selected code.

Ad| Lowercase Ctrl+alt+L | Changes selected text case to lowercase.
ad| Uppercase Ctrl+alt+0 | Changes selected text case to uppercase.
@ Titlecase Ctrl+alk+T | Changes selected text case to titlercase.
Find Text

Dialog box for searching the document for the specified text. The search is per-
formed in the direction specified. If the string is not found a message is displayed.

Find Text (w3

Search for: init -
—Options —Direction
Case sensitivity @ Forward

Whole words only

Search frorm caret HaEErT
Selected text anly
Regular expression (0] 4 Cancel
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Replace Text

Dialog box for searching for a text string in file and replacing it with another text string.

-

-

[1] Replace Text =nEeR==
Search far; mikroE lektronika -
Beplace with: rnik.roE -
—ption —Direction

@ Forward

“Wwhole words only

Search from caret Backward

Selected text only

Beqular exprezsion k. Cancel

Find In Files

Dialog box for searching for a text string in current file, all opened files, or in files on

a disk.

The string to search for is specified in the Text to find field. If Search in directories option
is selected, The files to search are specified in the Files mask and Path fields.

Grep search

s

—Options

Case sensitive

Whaole wards

Text to find: (gl = E S e

-

Where
Zurrent file

All opened files
@ Search in directories

—Search directory options

Files mask: *.*

Path: Ci\Program filesh,

Include subdirectories

QK

Cancel
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Go To Line

Dialog box that allows the user to specify the line number at which the cursor should

be positioned.

Go To Line

Go To Line Muber

1]

QK Cancel

]

Regular expressions

By checking this box, you will be able to advance your search, through Regular

expressions.

Find Text @
Search for: unsignedyxz0int -
—Options —Direction

Case sensitivity @ Forward

Whale words only

Search frorm caret - Backward

Selected text only

+ Reqgular expression i (0] 4 Cancel

Related topics: Keyboard shortcuts, Edit Toolbar, Advanced Edit Toolbar
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View Menu Options

o

Toolbars 3

Debug Windows k

Routines List
Project Settings
Caode Explorer
Project Manager  Cerl+F11
Library Manager

Bookmarks

Messages

Macro Editor

Windows

File

Description

-

Toolbars

Show/Hide toolbars.

Debug Windows

Show/Hide debug windows.

o=

Roukines Lisk

Show/Hide Routine List in active editor.

Project Sektings

Show/Hide Project Settings window.

=

Code Explorer

Show/Hide Code Explorer window.

Project Manager Shift+Ctrl+F11

Show/Hide Project Manager window.

Library Manager

Show/Hide Library Manager window.

Bookmarks Show/Hide Bookmarks window.

Messages Show/Hide Error Messages window.

Macro Editor Show/Hide Macro Editor window.
Windaows Show Window List window.

MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD
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TOOLBARS

File Toolbar

N&-HS  HE &

File Toolbar is a standard toolbar with following options:

Icon

Description

L]

Opens a new editor window.

(.

Open source file for editing or image file for viewing.

Save changes for active window.

Save changes in all opened windows.

HDI

Close current editor.

B

Close all editors.

=

Print Preview.

Edit Toolbar

@

Ie

Edit Toolbar is a standard toolbar with following options:

Icon

Description

Undo last change.

Redo last change.

Cut selected text to clipboard.

Copy selected text to clipboard.

il |7 82 |3 | 2

Paste text from clipboard.
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Advanced Edit Toolbar
Lalatotal SRR o)

Advanced Edit Toolbar comes with following options:

15
1

o |

Icon Description

Comment selected code or put single line comment if there is no
fuad selection

Uncomment selected code or remove single line comment if there is no
L selection.
E Select text from starting delimiter to ending delimiter.
Erit Go to ending delimiter.

] |Gotoline.

Indent selected code lines.

Outdent selected code lines.

Generate HTML code suitable for publishing current source code on
ud the web.

Find/Replace Toolbar

P RPA P

Find/Replace Toolbar is a standard toolbar with following options:

Icon Description

Find text in current editor.

Find next occurence.

Find previous occurence.

Replace text.

[0 o o

Find text in files.
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Project Toolbar
i e A ES Vi 1 T A O

Project Toolbar comes with following options:

Icon

Description

i

Open new project wizard. wizard.

Open Project

-

Save Project

Add existing project to project group.

Remove existing project from project group.

Add File To Project

| | [T | i | O

Remove File From Project

i

Close current project.

Build Toolbar

Build Toolbar comes with following options:

Icon

Description

Build current project.

Build all opened projects.

4
=

i s | o5

Build and program active project.

Start programmer and load current HEX file.

Open assembly code in editor.

B | &

View statistics for current project.
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Debugger

@

T By eo ey o2 ] | & &

Debugger Toolbar comes with following options:

Description

Icon
=h Start Software Simulator.
5h Run/Pause debugger.

Ex Stop debugger.

1) Step into.

e Step over.

38 Step out.

g Run to cursor.

= Toggle breakpoint.

= Toggle breakpoints.
(i, Clear breakpoints.

" View watch window

; View stopwatch window

Styles Toolbar

Office 2003 Blue ]

Office 2003 Olive
Qffice =P
Chocolate

Arctic

Silverfomx

Soft gand il

Styles toolbar allows you to easily customize your workspace.
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Tools Toolbar
L INE= R =]

Tools Toolbar comes with following default options:

Icon Description

= Run USART Terminal
= EEPROM
A ASCII Chart

@' Seven segment decoder tool.

The Tools toolbar can easily be customized by adding new tools in Options(F12) window.

Related topics: Keyboard shortcuts, Integrated Tools, Debugger Windows
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PROJECT MENU OPTIONS

N Build Ctrl+F9

i

Edit Search Paths., ..

Clean Project Folder, ..

Build &ll Projects Shift+F2

Build + Program Chrl+F11

Add File To Project...

Femove File From Project

BT

Open Project Group...

Close Project Group

L4 0 (8

Sawve Projeck As, .,

Mew Project. .. ShiftCErl+n

Qpen Project,..  Shift+Cerl40

Recent Projects

Close Project

(8
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Project Description
“# Buid Ctrl+Fa [Build active project.
A% Build Al Shift+F9 | Build all projects.
% Build + Program CtkrH-F11 | Build and program active project.
| Wiews Assembly View Assembly.

Edit Search Paths...

Edit search paths.

|lean Project Folder. ..

Clean Project Folder

4dd File To Project. .,

Add file to project.

Remove File From Project

Remove file from project.

Mew Projeck, .,

Open New Project Wizard

Qpen Project,..  Shift+Ckrl+0

Open existing project.

Save Projeck

Save current project.

open Project Group...

Open project group.

Zlose Project Group

Close project group.

AR E R B

Save Project As,..

Save active project file with the different name.

Recent Projects

Open recently used project.

Zlnse Project

0

Close active project.

Related topics: Keyboard shortcuts, Project Toolbar, Creating New Project, Project

Manager, Project Settings
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RUN MENU OPTIONS

[gb, Start Debugger Fa
[ﬂg Stop Debugger Ckrl+F2
éaj Pause Debugoer F&
i} Step Into F7
'ﬁu Step Qver F&
08 Skep Quk Chrl+Fa
# Jurnp To Interrupk Fz
E  Toggle Breakpoint FS
2= Breakpoints Shift-+F4
'8l | Clear Breakpoints  Shift+Crl+FS
&t Wakch Window Shift+F5
Ef—j Yiew Stopwatch

Disassembly mode alk+D
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Run Description
é@ Skart Debugger Fa | Start Software Simulator.
=4 Stop Debugger Ctrl+F2 | Stop debugger.
|'_§:]_| Pause Debugger Fs |Pause Debugger.
g1 Skep Inko F7 |Step Into.
@4, Shep Over Fg |Step Over.

Step Ot iCtrl+Fg | Step Out.

Jurnp T Inkerrupk Fz |Jump to interrupt in current project.

Toaggle Ereakpaoint FS | Toggle Breakpoint.

ShowHide Breakpoints  Shift+F4 | Breakpoints.

YWakch Window Shift+F5 | Show/Hide Watch Window

£
(=
l‘@ Clear Breakpoints  shift+Ctrl+FS | Clear Breakpoints.
e

Yieww Stopwatch Show/Hide Stopwatch Window

Toggle between Pascal source and dis-

Disassembly mode CrrlHD assembly.

Related topics: Keyboard shortcuts, Debug Toolbar
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TOOLS MENU OPTIONS

S

|
E
Al

El

mE Programmrer F11
SART Terminal ChEl+T
EEPROM Editor

Aacii Chart

Seven Segrment Convertor

]| Export Code To HTML

LCD Cuskar Characker
() GLCD Bitmap Editor

LIDP Terrminal
& Options Fl12

Tools Description

% mE Programmer F11 |Run mikroElektronika Programmer
Bl UsaRT Terminal trl+T |Run USART Terminal
5 EEPROM Editar Run EEPROM Editor
A Asci Chart Run ASCII Chart
@' Seven Segment Conwvertor Run 7 Segment Display Decoder

Export Code To HTML

Generate HTML code suitable for publishing
source code on the web.

LD Cusktom Character

Generate your own custom Lcd characters

k_h GLCD Bitmap Editor Generate bitmap pictures for Glcd
LDP Terminal UDP communication terminal.
S Options F1z |Open Options window

Related topics: Keyboard shortcuts, Tools Toolbar
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HELP MENU OPTION

&) Help F1

Check For Updates
mikroElekkronika Support Forums
mikroElekkronika Web Page

- How To Reqgister

Ahout
Help Description
@ Help F1 |Open Help File.
Quick Help.
Check For Updates Check if new compiler version is available.

Open mikroElektronika Support Forums in a
default browser.

Open mikroElektronika Web Page in a
default browser.

mikroElekkronika Support Farums

mikroElekkronika Web Page

' How Tao Reqister Information on how to register

About Open About window.

Related Topics:Keyboard shortcuts
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KEYBOARD SHORTCUTS

Below is a complete list of keyboard shortcuts available in mikroPascal PRO for AVR
IDE. You can also view keyboard shortcuts in the Code Explorer window, tab Keyboard.

IDE Shortcuts

F1 Help
Ctrl+N New Unit
Ctri+O Open
Ctrl+Shift+O Open Project
Ctrl+Shift+N Open New Project
Ctrl+K Close Project
CtrlI+F9 Compile
Shift+F9 Compile All
Ctrl+F11 Compile and Program
Shift+F4 Compile and Program
Ctrl+Shift+F5 Clear breakpoints
F11 Start AVRFlash Programmer
F12 Preferences

Basic Editor Shortcuts
F3 Find, Find Next
Shift+F3 Find Previous
Alt+F3 Grep Search, Find in Files
Ctrl+A Select All
CtrlI+C Copy
Ctrl+F Find
CtrI+R Replace
Ctrl+P Print
Ctrl+S Save unit
Ctrl+Shift+S Save All
Ctrl+Shift+V Paste
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Ctrl+X Cut
Ctrl+Y Delete entire line
Ctrl+Z Undo
Ctrl+Shift+Z Redo

Advanced Editor Shortcuts
Ctrl+Space Code Assistant
Ctrl+Shift+Space Parameters Assistant
Ctrl+D Find declaration
Ctrl+E Incremental Search
Ctrl+L Routine List
Ctrl+G Goto line
Ctrl+J Insert Code Template
Ctrl+Shift+. Comment Code
Ctrl+Shift+, Uncomment Code
Ctrl+number Goto bookmark
Ctrl+Shift+number Set bookmark
Ctrl+Shift+ Indent selection
Ctrl+Shift+U Unindent selection
TAB Indent selection
Shift+TAB Unindent selection
Alt+Select Select columns
Ctrl+Alt+Select Select columns
Ctri+Alt+L Convert selection to lowercase
CtrlI+Alt+U Convert selection to uppercase
Ctri+AlIt+T Convert to Titlecase
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Software Simulator Shortcuts
F2 Jump To Interrupt
F4 Run to Cursor
F5 Toggle Breakpoint
F6 Run/Pause Debugger
F7 Step into
F8 Step over
F9 Debug
Ctrl+F2 Reset
Ctrl+F5 Add to Watch List
CtrlI+F8 Step out
Alt+D Dissasembly view
Shift+F5 Open Watch Window
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IDE OVERVIEW

The mikroPascal PRO for AVR is an user-friendly and intuitive environment:

n] R PRl for AVFIE T Ew
B Edit Yerw Project fun Tooks |Hep
ke FERERR-.-) LD D S a@m BOAEL R PR
B (680 (LR [ (| en @y 06 o @ 1) G | e (5 [ Otioe 2000BRe -
= Led.mpas P R O uteary Mansger " Wch Vakues 7B
[ begin B 0 (e ) BN R 60 &, oo of | w 5@
Delay_ms (500) 2 // You can change the moving speed here 3 g : o
| A R remoe ™
50 St wasabln o bt =t
|& begin o . o
] Saach for vasistle by acveniy name: =
RHEL i= 'miXEGELENTEORAKA'} o £
BAEZ 1% 'EASTAVRSA': &
naEd 1= Legdbint: B
TATA 1= exmmplets - ) S
. ol {k oo0l 4
[&] 0% LR
Lod_Cid (LED_CLEAR) 3 /F Clear dispiay 1 105 e
Led_Cmd (LCD_CURSOR_OFT) 2 £/ cusser off @ 07 OeE
50 LCD_Que (1,6, exed): /4 Write text in first roew el H et0i>
LED_Oue {2, 6, txcd) 2 /7 Weits text in second Eow 2 m outiee
Delay_me (2000} 5] & e
Led_Cmd (LED_CLEAR) 3 /4 Clear display O] 18 eo0m
m 0 Tt
1.C0 I U] 107 otz
LED_but (2, 4, txci}s i 1 18 o073
Delay_ms(500) H [0} 1 o074
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b
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: bEACD_RS: e - PC= BO0MIC
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N Insert ChmikroPascal PRO for AVR\E

- The Code Editor features adjustable Syntax Highlighting, Code Folding, Code Assistant,
Parameters Assistant, Spell Checker, Auto Correct for common typos and Code Tem
plates (Auto Complete).

- The Code Explorer (with Keyboard shortcut browser and Quick Help browser) is at your
disposal for easier project management.

- The Project Manager alows multiple project management

- General project settings can be made in the Project Settings window

- Library manager enables simple handling libraries being used in a project

- The Error Window displays all errors detected during compiling and linking.

- The source-level Software Simulator lets you debug executable logic step-by-step by
watching the program flow.

- The New Project Wizard is a fast, reliable, and easy way to create a project.

- Help files are syntax and context sensitive.
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- Like in any modern Windows application, you may customize the layout of
mikroPascal PRO for AVR to suit your needs best.

- Spell checker underlines identifiers which are unknown to the project. In this way it helps
the programmer to spot potential problems early, much before the project is compiled.

- Spell checker can be disabled by choosing the option in the Preferences dialog (F12).
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CUSTOMIZING IDE LAYOUT

Docking Windows

You can increase the viewing and editing space for code, depending on how you
arrange the windows in the IDE.

Step 1: Click the window you want to dock, to give it focus.

] % LedBlinking.mppay
4007 Sources

o LedBlinking. mpas

i {7 Binaries

-7 Project level defines

i) Image Files

{77 Qukput Files

Step 2: Drag the tool window from its current location. A guide diamond appears.
The four arrows of the diamond point towards the four edges of the IDE.
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Step 3: Move the pointer over the corresponding portion of the guide diamond. An
outline of the window appears in the designated area.

Step 4: To dock the window in the position indicated, release the mouse button.

Tip: To move a dockable window without snapping it into place, press CTRL while
dragging it.

Saving Layout

Once you have a window layout that you like, you can save the layout by typing the
name for the layout and pressing the Save Layout Icon E .

To set the layout select the desired layout from the layout drop-down list and click
the Set Layout Icon .

To remove the layout from the drop-down list, select the desired layout from the list
and click the Delete Layout Icon .

Diebug Layout

<Default Layout:
Code Layout

Debug Layout
layout
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Auto Hide

Auto Hide enables you to see more of your code at one time by minimizing tool windows
along the edges of the IDE when not in use.

- Click the window you want to keep visible to give it focus.
- Click the Pushpin Icon Z£ on the title bar of the window.

[l ]
E=| Project Manager ]
) W ; L=
— — —
A-\% FirstProject.mppay 2= [E=] Project Mana 5=
4 -] Sources il = - -
g secondProject. mpas |— —| b % —
[ Binaries 4| 4 13)_7 FirstPro g gE] E
1 Project level defines N 44 E_IDLIFI % P
] Image Filas ElE % Tl %.
) Oukput Files [ Binary = at
[ Other Files [ Proje =
1 Imag é
[ Cutp 2
- 7tk -
EREEEEEEEEEEEE EEEE A = =
IIIIIIIIIIIIIIIIIIIII’
w

When an auto-hidden window loses focus, it automatically slides back to its tab on the edge
of the IDE. While a window is auto-hidden, its name and icon are visible on a tab at the edge
of the IDE. To display an auto-hidden window, move your pointer over the tab. The window
slides back into view and is ready for use.
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ADVANCED CODE EDITOR

The Code Editor is advanced text editor fashioned to satisfy needs of professionals.
General code editing is the same as working with any standard text-editor, including
familiar Copy, Paste and Undo actions, common for Windows environment.

Advanced Editor Features

- Adjustable Syntax Highlighting

- Code Assistant

- Code Folding

- Parameter Assistant

- Code Templates (Auto Complete)
- Auto Correct for common typos

- Spell Checker

- Bookmarks and Goto Line

- Comment / Uncomment

You can configure the Syntax Highlighting, Code Templates and Auto Correct from
the Editor Settings dialog. To access the Settings, click Tools » Options from the
drop-down menu, click the Show Options Icon g or press F12 key.
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Options

==

IV Editor

Project Files

W Restore Last Opened Praject

W Save Breakpaints

Editor Settings

" Restore all Opened Files

W Save Bookmarks

TF Opened File Is Externally Modified
[C‘ Prampt For action

@ Relnad file, but do not prompk

() Ignore externally made changes

AUt Save

W Enable Auto Save
Highlighter

[ Highlight: beqin..end pairs
W Highlight: brackets
Speling

W Check speling

Timeout Interval: 3

minutes

Comment skyle
®

@ {f {single line)

Advanced Editor Options

3 Open options dialog

Code Folding
W Enable code falding

I Show Ident Guides

Apply Cancel

Code Assistant

If you type the first few letters of a word and then press Ctrl+Space, all valid identifiers match-
ing the letters you have typed will be prompted in a floating panel (see the image below). Now
you can keep typing to narrow the choice, or you can select one from the list using the key-
board arrows and Enter.

sp

wariahle
wvariable
wariahle

sfr GPDR: byte
sfr SPeR: byte
sfr SPCR: byte
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Code Folding

Code folding is IDE feature which allows users to selectively hide and display sec-
tions of a source file. In this way it is easier to manage large regions of code within
one window, while still viewing only those subsections of the code that are relevant
during a particular editing session.

While typing, the code folding symbols (|| and ) appear automatically. Use the
folding symbols to hide/unhide the code subsections.

h?egin

PORTL :=0;

PORTE :=0;

Led Init():

LoD Out(1,1,txt[0]);
LCD_out{Z,1,txt[1]):
delay ms(1000] ;

Led Cmd(l):

LCD_Ouril,1,txt[1]):
LCD _Out(Z,4,txt[Z2]):
delay ms(500) ;

end.

hegin |_|

If you place a mouse cursor over the tooltip box, the collapsed text will be shown in
a tooltip style box.

hegin [?ﬂ
i o
begin

PORTL := 0;

PORTE := 0;

Led Indit ()

LCD_out (1,1,txt[0]);
LCD out(2,1,txc[1]);
delay _ms (1000) ;

Led Cmd (1)

LD out(1,1,.txt[1]):
LeD out (2,4, txt[2]);
delay ms(500) ;

end;
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Parameter Assistant

The Parameter Assistant will be automatically invoked when you open parenthesis
“(” or press Shift+Ctrl+Space. If the name of a valid function precedes the parenthe-
sis, then the expected parameters will be displayed in a floating panel. As you type
the actual parameter, the next expected parameter will become bold.

channel : byte
ADC Res

Code Templates (Auto Complete)

You can insert the Code Template by typing the name of the template (for instance,
whiles), then press Ctrl+J and the Code Editor will automatically generate a code.

You can add your own templates to the list. Select Tools » Options from the drop-
down menu, or click the Show Options Icon g‘ and then select the Auto Com-
plete Tab. Here you can enter the appropriate keyword, description and code of your
template.

Autocomplete macros can retreive system and project information:

- $DATES - current system date

- $TIMES - current system time

- ¢DEVICES - device(MCU) name as specified in project settings
- $DEVICE CLOCKS - clock as specified in project settings

- $COMPILERS - current compiler version

These macros can be used in template code, see template ptemplate provided with
mikroPascal PRO for AVR installation.

Auto Correct

The Auto Correct feature corrects common typing mistakes. To access the list of rec-
ognized typos, select Tools » Options from the drop-down menu, or click the Show
Options Icon g‘ and then select the Auto Correct Tab. You can also add your
own preferences to the list.

Also, the Code Editor has a feature to comment or uncomment the selected
code by simple click of a mouse, using the Comment Icon .} | and Uncom-
ment Icon {1 | from the Code Toolbar.
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Spell Checker

The Spell Checker underlines unknown objects in the code, so they can be easily
noticed and corrected before compiling your project.

Select Tools » Options from the drop-down menu, or click the Show Options
Icon g and then select the Spell Checker Tab.

Bookmarks

Bookmarks make navigation through a large code easier. To set a bookmark, use
Ctrl+Shift+number. To jump to a bookmark, use Ctrl+number.

Goto Line

The Goto Line option makes navigation through a large code easier. Use the short-
cut Ctrl+G to activate this option.

Comment / Uncomment

Also, the Code Editor has a feature to comment or uncomment the selected
code by simple click of a mouse, using the Comment Icon {1 and Uncom-
ment Icon {1 from the Code Toolbar.

MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD 43



CHAPTER 2
Environment mikroPASCAL PRO for AVR

CODE EXPLORER

The Code Explorer gives clear view of each item declared inside the source code.
You can jump to a declaration of any item by right clicking it. Also, besides the list of
defined and declared objects, code explorer displays message about first error and
it's location in code.

Code Explarer [
=gl
QUses
4 [@main
- @ LCD RS
@ LCD_EM
- @ LCD D4
@ LCD_DS
- @ LCD D6
@ LCDh D7
@ LCD_RS_Direction
@ LCD_EMN_Direction
~ @ LCD_D4_Direction
@ LCD_DS_Direction
- @ LCD_DA_Direction
@ LCD_D7_Direction
S vau |
@tz
S o'y o]
@ twtd
@
GMove_Dela\;

Icon Description

Tg’ Expand/Collapse all nodes in tree.

e Locate declaration in code.
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ROUTINE LIST

Routine list diplays list of routines, and enables filtering routines by name. Routine list win-
dow can be accessed by pressing Ctrl+L.

You can jump to a desired routine by double clicking on it.

[0 Liwary tosnsger
IR ] o] ]

0= L e e e T e e e o e e e =T
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PROJECT MANAGER

Project Manager is IDE feature which allows users to manage multiple projects.
Several projects which together make project group may be open at the same time.
Only one of them may be active at the moment.

Setting project in active mode is performed by double click on the desired project
in the Project Manager.

Project Manager =]
g | 2 | B 20 ey | [P | S0
.11_-{‘_, LedBlinking.mppay
4. Sources
% LedElinking.mpas
[ Binaries
1 Project level defines
1 Image Files
-] Qutpuk Files
5| LedBlinking. hex
£=| LedBlinking, asm
% LedBlinking. |st
(1 Other Files

Following options are available in the Project Manager:
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Following options are available in the Project Manager:

Icon Description

Save project Group.

Open project group.

Close the active project.

Close project group.

Add project to the project group.

Remove project from the project group.

Add file to the active project.

Remove selected file from the project.

Build the active project.

[ | U] O | (| Cs | 08| G5 | 58 | P

Run mikroElektronika's Flash programmer.

For details about adding and removing files from project see Add/Remove Files
from Project.

Related topics: Project Settings, Project Menu Options, File Menu Options, Project
Toolbar, Build Toolbar, Add/Remove Files from Project
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PROJECT SETTINGS WINDOW

Following options are available in the Project Settings Window:

- Device - select the appropriate device from the device drop-down list.
- Oscillator - enter the oscillator frequency value.

I—lﬂ
Project Settings

Name: | 4TMEGALE -

oo I

Value: | 10.000000| MHz
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LIBRARY MANAGER

Library Manager enables simple handling libraries being used in a project. Library
Manager window lists all libraries (extencion .mc1) which are instantly stored in the
compiler Uses folder. The desirable library is added to the project by selecting check

box next to the library name.

In order to have all library functions accessible, simply press the button Check All

"] and all libraries will be selected. In case none library is needed in a project,

press the button Clear All "] and all libraries will be cleared from the project.

Only the selected libraries will be linked.

Library banager [

» ] aDc

> [7] Butkon

Ol _Type

- [¥] cam_sPI

- [] Compact_Flash_FaT16
> [T] Compact_Flash
> [7] Conversions

- [ EEFROM

- [ FLASH

L[] Gled_Fants

- [¥] Gled

> [0 kevpaddxd
&[T Led_Constants
2 [ Led

> [] Manchesker

- [ Mmc_FaT16

> [ Mmc

> 0] One_Wire

- [¥] Part_Expandsr
2 [ psz

> [T P

- O] et

- [ rs4as

> [7] software_I2C
> [7] Software_SPI
> [7] Software_UART
> [0 sound

- ] sP1_lcd

- [7] 5PI_Led

- ] SPI_Leds

- [¥] SPI_TR9R3C

- [C] Teeeac

> [ Time

> [T] Trigonometry

- 0] Tw
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Icon Description
= Refresh Library by scanning files in "Uses" folder.Useful when new
= libraries are added by copying files to "Uses" folder.
Y Rebuild all available libraries. Useful when library sources are available and
e need refreshing.
W Include all available libraries in current project.
i No libraries from the list will be included in current project.
= Restore library to the state just before last project saving.

Related topics: mikroPascal PRO for AVR Libraries, Creating New Library
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ERROR WINDOW

In case that errors were encountered during compiling, the compiler will report them and won’t gener-
ate a hex file. The Error Window will be prompted at the bottom of the main window by default.

The Error Window is located under message tab, and displays location and type of errors the
compiler has encountered. The compiler also reports warnings, but these do not affect the out-
put; only errors can interefere with the generation of hex.

Messages =]
Errors ‘Warnings Hinks
Line Message Mo,  Message Text Lnik
o 1 mP&VR.exe -DEG -pATMEGALE -MSF -¥ -DL -011111114 -fod -..,
0 132 Carnpilation Started CPROGRAM FILES|MIKROELEKTRONIKAMIKROPASCAL PRO FOR AVRY...
43 304 Swntax error: Expected ") buk "end" Found Sound.mpas
45 301 "procedure"is not valid idenkifier Sound.mpas
45 304 Syntax error: Expected "end" but "procedure Found Sound.mpas
45 304 Syntax error: Expected ;" buk "Melody” Found Sound.mpas
45 304 Swntax error: Expected "." but (" Found Sound.mpas
i} 102 Finishied {with errors): 29 Moy 2008, 09:35:07 Sound. mppasy

Double click the message line in the Error Window to highlight the line where the error was
encountered.

Related topics: Error Messages
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STATISTICS

After successful compilation, you can review statistics of your code. Click the Statistics

Icon [fid .

Memory Usage Windows
Provides overview of RAM and ROM usage in the form of histogram.

RAM MEMORY
Rx Memory Space

Displays Rx memory space usage in form of histogram.

Statistics

4 - Memory Usage

RAM Memory Usage (locations)

| 50% ot 32 | 16 Free RxDsta RAM
16 Uzed RxData RAM

- ROM Allocation
4 Procedures

‘- Locations
- HTHL

Free RxData Rahd Uszed RxData R
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Data Memory Space

Displays Data memory space usage in form of histogram.

4 - Memory Uzage

1,015 Free data RAM
9 Used data RAM

- AOM Allocation
4 - Procedures

- Size

- Locations

Special Function Registers

Summarizes all Special Function Registers and their addresses.

4 -Memory Usage
4 RAM Special function registers [SFR)
Rl ata
% Address Register
SFR 0x00
GPR 0401 A1

4 ROM
‘.. FOM Allacation D42 A2

4 Procedures 0:03 R3
o Size 0:04 R4
- Locations 005 RS
= HTHL 0406 Rt
007 R7
0x08 R&
003 R3
004 R10
0x0B R11
0:0C R12
000 R13
0x0E R14
0:0F R15
010 R16
011 R17
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General Purpose Registers

Summarizes all General Purpose Registers and their addresses. Also displays sym-
bolic names of variables and their addresses.

Statistics

4 - Memory Uszage

General purpose registers [GPR]
Address Register
Ox60 E: [_Lib i ]
0«62 DefDevicedddress  [__Lib SPIGled_DefDevicedddiess)
. FIOM Allocation 063 spifontwd Lk SPIGIed_spitontw]
4 - Procedures 064 spifontH  [__Lib_SPIGIcd_spifontH]
é---Size 065 spifontDef  [_spifontDief]
- Locations 0467 Sp_Ad Ph o [Spi_Rd Pl
“ HTML

Inaccessible color  [FARG_SPI_Gled_H_Line+3)

Inaccessible loc  [SPI_Gled_H_Line_loc_L0)

Inaccessible y_poz  [FARG_SPI_Gled_H_Line+2)

Inaccessible «_start  [FARG_SPI_Glod_H_Line+0]

Inaccessible #_end  [FARG_SPI_Gled_H_Line+1)

Inaccessible data_out [FARG_SPI1_Read+0]

Inaccessible colar  [FARG_SPI_Gled_W_Line+3)

Inaccessible loc  [SPI_Gled %_Line_loc_L0)

Inaccessible #_poz  [FARG_SPI_Gled_V_Line+2)

Inaccessible y_stat  [FARG_SPI_Gled V_Line+0]

Inaccessible y end [FARG_SPI_Glcd ¥ _Line+1] I
Inaccessible Flatrl _SPI_Gled =

ROM MEMORY
ROM Memory Usage

Displays ROM memory usage in form of histogram.

Statistics

4 - Memory Uszage
4 600 Free ROM
9,734 Used RO

ROM Memory Usage (ytes)

.. ROM Allacation
4 - Procedures

Size

. Locations
“ HTML

Fres ROM Lized ROM
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ROM Memory Allocation
Displays ROM memory allocation.
Statistics =
4 Memery Usage 020000  0x0CI4ZA ~
Ox0004  0x0C3400 ‘_W
0x0008 0x0C2400 I
0x000C  0x0CS9400
0x0010  0x0CI400
0Ox0014  0x0C3400
. 0x0018 0x0C2400
H = 0x001C 0x0CS9400
Bk Al aticr 0x0020  0x009400
4 -Procedures 0x0024  0x0C5400
Size 0x00Z8  0x0C9400
i Locations 0x00ZC  0x0C9400
- HTML 0x0030  0x0CI400
0Ox0034  0x0C3400
0x0038 0x0C2400
0x002C  0x0CS9400
0x0040  0x0CI400
Ox0044d  0x0C3400
0x0048 0x0C2400
0x004C  0x0CS9400
0x0050  0x0CI400
Ox15FZ OxZZES
Ox15F4 OxlBEZ
Ox1E5F& 0x00ED
0xLEFS  0x0A9E
Ox15FA OxFlF7
Ox15FC Oxlast
4 »
Procedures Windows
Provides overview procedures locations and sizes.
Procedures Size Window
Displays size of each procedure.
Statistics B
4 - Memory Uzage |
4-Ram ROM usage by procedure (ROM locations)
- RxData ; : i !
'g::' Delay_1us £ : - : : :
'GPH HrMUI_1 Bx16 §
4 Ao Expanch RSP: _j E:Ad
L ROM Allacation . er_. ea. e
4 Procedures Expander_Set_DirectionPortB
= Expander_Wiite_PortB
i Locations SPH _Init_Advanced
o HTML SPI_Gled__Line

SPI_Glod_Set_Paoe
SPI_Strobe
SPI_Gled_Set_Side
Expander_Wiite_Byte
SP|_Glcd_Rectangle
SPI_Glod_Read_Data
SPI_Glod_Fil
SPI_Glod_Image
SPI_Glod_Line

main

200 300
ROM locations
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Procedures Locations Window

Displays how functions are distributed in microcontroller’'s memory.

4 - Memory Uzage

HTML Window

Display statistics in default web browser.

4 -Memory Usage
You can generate statistics in HTML format too. it is suitable for printing and for documenting your
project.

Press the button bellow to generate HTML statistics and to open them in the default web browser

- ROM Allacation
4 - Procedures iews HTML stalistics
Size
- Locations
-~ HTML
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INTEGRATED TOOLS

USART Terminal

The mikroPascal PRO for AVR includes the USART communication terminal for
RS232 communication. You can launch it from the drop-down menu Tools » USART
Terminal or by clicking the USART Terminal Icon Eli from Tools toolbar.

RS232 Terminal =]
—Settings —Communication
Corn Port: Echo Send '?'la
' Q600 7 : i [ F
Baud: Append: © CR Send as 8N (oo Logaing |
Stop Bits: (9N Stap Bit e LF Send as number
. Clear Histo
Check Parity R‘_ecewe data a - -
: - @ ASCII 1 HEX ) DEC
Data bits: |Eight -4
Command Connected to COM3 -
R_IS Q_TR Sent: Echo
9 off @ off
" on " on

Connect | Lisconmect

—Statu
Send Receive CTS DsR
[*] [*] [~ ©
—Log File
o
Read from:
Mrite to:

W Append to W Create file
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ASCII Chart

The ASCII Chart is a handy tool, particularly useful when working with Lcd display.
You can launch it from the drop-down menu Tools » ASCII chart or by clicking the
View ASCII Chart lcon | from Tools toolbar.

Ascii Chart [

of1|2|3|4 | 5|6 |7 |8 |9 |A|B|C|D|E F

MNUL SOH STX ETx EOT EMNOQ ACK BEL |BS HT LF ¥T FF CR |50  SI

0
u] 1 2 3 4 5 =] 7 g El 10 11 12 13 14 15
4 |PLE DC1 DC2 DC3 DC4 NAK SYN ETB CAN EM SUB ESC FS GS RS US
16 17 18 19 20 21 22 23 24 25 26 27 25 29 30 3l
o |SPC ! " # % % N N A T T I I I
32 33 a4 35 36 37 1] 39 40 41 42 43 44 45 46 47
g|?|1[2|3[4|5 (6|7 (8|09 :|; |[<|=[>]?
45 49 50 51 52 53 54 =) 56 57 55 59 (=11 (=} 62 63
4|® A B C D E F G H I 1 K L M N O

64 | 65 | 66 | 67 | B8 69 | Y0 | 7l | YE | V3 V4 | Y5 Ve | Y7 Ve | 79
5 P O R S5 T Uu ¥ W X Y |2 [ b, ] =

g0 | 81 | 82 | 83 | 8 | 85 | 86 92 | 93 [ 94 | 95

6 N a b ¢ d e f | m ©n O

96 | 97 | 9% | 99 | 100 | 101 | 102 108 | 109 | 110 111
7 P q r s t u v | ¥ ~ DEL

112 | 113 | 114 115 | 116 | 117 | 118 124 | 125 | 126 | 127
8 E ’ F R . T E 2

128 | 129 | 130 | 151 | 132 | 133 | 134 | 135 | 136 | 157 | 138 | 139 | 140 | 141 [ 142 | 143

1 » u » - _ _ - T H y o= 3 ili

]

144 | 145 | 146 | 147 | 148 | 149 | 150 | 151 | 152 | 153 | 154 | 155 | 156 | 157 | 158 | 159
A i ¢ | £ | o | ¥ i g BRI “ a0 - B

160 | 161 | 162 | 163 | 164 | 165 | 166 | 167 | 168 | 169 | 170 | 171 | 172 | 173 [ 174 | 175
gl £/ " w9 -, t]0o » v e % i

176 [ 177 | 178 | 179 | 180 | 151 | 152 | 183 | 184 | 185 | 186 | 187 | 185 | 189 [ 190 | 191
C AlA A A A A |E C E E E E I 1 I 1

192 | 193 | 194 | 195 | 195 | 197 | 195 | 199 | 200 | 201 | 202 | 203 | 204 | 205 | 206 | 207
D b N ] ] ] ] 0 ® @ u u u u Y u] n

208 [ 209 | 210 | 211 | 212 | 213 | 214 215 | 216 | 217 | 218 | 219 | 220 | 221 | 222 | 223
e |2 4 a/a a & a|c¢c|e | 6 |&| &8 i i i|T
224 | 225 | 226 | 227 | 220 | 229 | 230 | 231 | 232 | 233 | 234 | 235 | 236 | 237 | 236 | 239
F a A o o6 | 46 o o6 | +|&e 0 o 0| a v p| @
290 | 241 | 242 | 243 | 244 | 245 | 246 | 247 | 248 | 299 | 250 | 251 | 252 | 253 | 254 | 258
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EEPROM Editor

The EEPROM Editor is used for manipulating MCU's EEPROM memory. You can
launch it from the drop-down menu Tools » EEPROM Editor. When Use this EEPROM
definition is checked compiler will generate Intel hex file project_name.ihex that con-
tains data from EEPROM editor.

When you run mikroElektronika programmer software from mikroPascal PRO for AVR
IDE - project name.hex file will be loaded automatically while inex file must be
loaded manually.

mikraElektronika EEFROM Tool |
i//' E E PROM Editor [[]use Eeprom in project Help

Device: EEPROM Size: EEPROM Fill: EEPROM File

Custom = vislzB‘ftes ¥alue: Ox FF | Fill | | Load | | Save |

EEPROM Data

[IE) FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF PV RV
[IEl rF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF PR
[IX) FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF R R
[IEl rF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF PR
[2) FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF ¥

[T}{) FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF ST RV
(i) FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FRPVE R
[T} FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF YRRV <
EEPROM Edit:

Input Format: Edit Yalue:

n EEPROM Address: i —

| Dec Hex No: Ox Edit

@ Hex Start Address: 0% FFFF

- Float Il Size:

= oa | AutoInc | Byte ) Word @ DWord

) String
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7 Segment Display Decoder

The 7 Segment Display Decoder is a convenient visual panel which returns deci-
mal/hex value for any viable combination you would like to display on 7seg. Click on
the parts of 7 segment image to get the requested value in the edit boxes. You can
launch it from the drop-down menu Tools » 7 Segment Decoder or by clicking the
Seven Segment Icon |E| from Tools toolbar.

Seven Segment Editor B

Common cathode:
0w

Common anode:
Decoding Farmat:
' Decimal
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UDP Terminal

The mikroPascal PRO for AVR includes the UDP Terminal. You can launch it from
the drop-down menu Tools » UDP Terminal.

UDP Communication Terminal -7 |[=]
Settings
|P &ddress: |192.16%.20.25
Port: 10001
Send:
| riikroE lektranik a Send
Append: [ CR [~ Send as typing
[~ LF [~ Send as number
mikroE lektronik.a -
P b
Clear
Receive
& ASCII " HE= " DEC

Clear
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Graphic Lcd Bitmap Editor

The mikroPascal PRO for AVR includes the Graphic Lcd Bitmap Editor. Output is the
mikroPascal PRO for AVR compatible code. You can launch it from the drop-down menu
Tools > Glcd Bitmap Editor.

|mikrcEIektrcnilca Graphic LCD Bitmap generator

File lnaded: truck.bmp

Pickure preview — 128x64 pix J bw
[ LoadBMPFictors |

[ Create CODE |

EE——
[ invertPIcTURE |

GLCD Size | controller

'
s GLCD Picture name: truck.bmp
#¢ GLCD Model: KS@1iA8 128x64

o

m| »

Copy CODE to Clipboard

const truck_bmp aEray[1824] of hyte = ¢

»

- 8. B8, - - - - » 8. 8. B, 12, 12, 12, 12.
12. 1@, 18, 18, 18, 18, 18, 2. 9?7, 2. 2. 9, - 2. - -
2. 9. 9, - 9. 9. 2, » 9. 2.137.137,137.137.137.137.
137.13%7.137,132.137.137,137,. 2, 2. 2. 2. 2. 9. 2. 9. 2.
‘J‘B, %, 1%.25%, 1%.193, 63,25%. g. g, g. g. g, g. g. g,

ver: 2,01 - 27012005 System status: Win NT like OS
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Lcd Custom Character

mikroPascal PRO for AVR includes the Lcd Custom Character. Output is mikroPas-
cal PRO for AVR compatible code. You can launch it from the drop-down menu
Tools > Lcd Custom Character.

.__“ LCD custom character E!—F—'
B & -
e = = = = =
hx{ Hx10 Save.. Load... Fill all Clear all Invert
Font ————— Preview:

* Bw 7+ curzor line
By 10+ cursor line

CGRAM address:

Char: Il:I 3"
Char data row: Il:I 3"

GENERATE
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MACRO EDITOR

A macro is a series of keystrokes that have been 'recorded' in the order performed.
A macro allows you to 'record' a series of keystrokes and then 'playback’, or repeat,
the recorded keystrokes.

Macros &
o b |1 | &

Mame

Macrod

1| 1] ' b

The Macro offers the following commands:

Icon Description

o Starts 'recording' keystrokes for later playback.

Ei? Stops capturing keystrokesthat was started when the Start Recordig com-
mand was selected.

;@3’ Allows a macro that has been recorded to be replayed.
= New macro.
G Delete macro.

Related topics: Advanced Code Editor, Code Templates
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OPTIONS

Options menu consists of three tabs: Code Editor, Tools and Output settings

Code editor

The Code Editor is advanced text editor fashioned to satisfy needs of professionals.

Tools

The mikroPascal PRO for AVR includes the Tools tab, which enables the use of shortcuts to

external programs, like Calculator or Notepad.
You can set up to 10 different shortcuts, by editing ToolO - Tool9.

Tool Mame: Taold

File Name: Press button to open File dialog

Parameters:

Macio: s5HEX_FILE_MAE Fullpath andnams of the o, +  Insatt

F11 -

$ Clear ol fields |

Output
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Output settings

By modifying Output Settings, user can configure the content of the output files.
You can enable or disable, for example, generation of ASM and List file.

Also, user can choose optimization level, and compiler specific settings, which include case sensitiv-
ity, dynamic link for string literals setting (described in mikroPascal PRO for AVR specifics).

Build all files as library enables user to use compiled library (+ .mc1) on any AVR MCU (when this
box is checked), or for a selected AVR MCU (when this box is left unchecked).

For more information on creating new libraries, see Creating New Library.

Optiong @

Cukput Setkings

W Generate ASM file
¥ Indude HEX opcodes
¥ Include ROM constants
¥ Include ROM Addresses

W Generate list File
V' Indude debug info

W Incdude source lines in oukput Files

Optimization level:

Four =

Compiler

W Case sensitive
W' Drynamic link For string literals

W Build all files as library

oK Apply Cancel
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REGULAR EXPRESSIONS
Introduction

Regular Expressions are a widely-used method of specifying patterns of text to
search for. Special metacharacters allow you to specify, for instance, that a particu-
lar string you are looking for, occurs at the beginning, or end of a line, or contains n
recurrences of a certain character.

Simple matches

Any single character matches itself, unless it is a metacharacter with a special
meaning described below. A series of characters matches that series of characters
in the target string, so the pattern "short" would match "short" in the target string.
You can cause characters that normally function as metacharacters or escape
sequences to be interpreted by preceding them with a backslash "\ .

For instance, metacharacter "~" matches beginning of string, but "\~" matches
character "~", and "\\" matches "\", etc.

Examples :

unsigned matches string 'unsigned'
\ “unsigned matches string '“unsigned'’

Escape sequences

Characters may be specified using a escape sequences: "\n" matches a newline,
"\ t" a tab, etc. More generally, \xnn, where nn is a string of hexadecimal digits,
matches the character whose ASCII value is nn.

If you need wide (Unicode) character code, you can use '\x{nnnn}', where 'nnnn'
- one or more hexadecimal digits.

\xnn - char with hex code nn

\x{nnnn) - char with hex code nnnn (one byte for plain text and two bytes for Unicode)
\t - tab (HT/TAB), same as \x09

\n - newline (NL), same as \x0a

\r - car.return (CR), same as \x0d

\£ - form feed (FF), same as \x0c

\a - alarm (bell) (BEL), same as \x07

\e - escape (ESC) , same as \x1b

Examples:

unsigned\x20int matches 'unsigned int' (note space in the middle)
\tunsigned matches 'unsigned' (predecessed by tab)
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Character classes

You can specify a character class, by enclosing a list of characters in [ 1, which will
match any of the characters from the list. If the first character after the [ " is "~",
the class matches any character not in the list.

Examples:

count[aeiou]r finds strings 'countar', 'counter', etc. but not 'countbr',
"countcr', etc.

count[*aeiou]r finds strings 'countbr', 'countcr', etc. but not 'countar’,

'counter', efc.

Within a list, the "-" character is used to specify a range, so that a-z represents all
characters between "a" and "z", inclusive.

If you want "-" itself to be a member of a class, put it at the start or end of the list,
or precede it with a backslash.
If you want '], you may place it at the start of list or precede it with a backslash.

Examples:

[-az] matches 'a', 'z' and '-'
[az-] matches 'a', 'z'and '-’
[a\-z] matches 'a', 'z'and '-'

[a-z] matches all twenty six small characters from 'a' to 'z’
[\n-\x0D] matches any of #10,#11,#12, #13.

[\d-t] matches any digit, '-' or 't'.
[1-a] matches any char from ']'.."a".
Metacharacters

Metacharacters are special characters which are the essence of regular expres-
sions. There are different types of metacharacters, described below.

Metacharacters - Line separators

~ - start of line

$ - end of line

\2 - start of text

\z - end of text

. - any character in line
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Examples:

~PORTA - matches string ' porT2a ' only if it's at the beginning of line
PORTAS - matches string ' porT2 ' only if it's at the end of line
~PORTAS - matches string ' porTa ' only if it's the only string in line
PORT . r - matches strings like 'PORTA', 'PORTB', 'PORT1' and SO On

The "~ metacharacter by default is only guaranteed to match beginning of the input
string/text, and the "$" metacharacter only at the end. Embedded line separators
will not be matched by ~" or "s".

You may, however, wish to treat a string as a multi-line buffer, such that the "~ will match
after any line separator within the string, and "$" will match before any line separator.
Regular expressions works with line separators as recommended at
http://www.unicode.org/unicode/reports/tr18/

Metacharacters - Predefined classes

\w - an alphanumeric character (including " ")

\w - a nonalphanumeric character

\d - a numeric character

\D - a non-numeric character

\s - any space (same as [\t\n\r\£])

\s - a non space

You may use \w, \d and \s within custom character classes.

Example:

routi\de - matches strings like 'routile', 'routiée' and so on, but not 'routine’,
"routime' and so on.

Metacharacters - Word boundaries

Aword boundary ("\b") is a spot between two characters that has an alphanumeric char-
acter ("\w") on one side, and a nonalphanumeric character ("\w") on the other side (in
either order), counting the imaginary characters off the beginning and end of the string as
matching a "\w".

\b - match a word boundary)
\B - match a non-(word boundary)
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Metacharacters - Iterators

Any item of a regular expression may be followed by another type of metacharac-
ters - iterators. Using this metacharacters,you can specify number of occurences of
previous character, metacharacter or subexpression.

* - zero or more ("greedy"), similar to {0,}

+ - one or more ("greedy"), similar to {1,}

2 - zero or one ("greedy"), similar to {0,1}

{n} - exactly n times ("greedy")

{n,} - at least n times ("greedy")

{n,m} - at least n but not more than m times ("greedy")
*2 - zero or more ("non-greedy"), similar to {0,}?

+? - one or more ("non-greedy"), similar to {1,}?

22 - zero or one ("non-greedy"), similar to {0,1}?

{n}? - exactly n times ("non-greedy")

{n,}? - at least n times ("non-greedy")

{n,m}? - at least n but not more than m times ("non-greedy")

So, digits in curly brackets of the form, { n, m} , specify the minimum number of times to
match the item n and the maximum m. The form {n} is equivalent to {n,n} and matches
exactly n times. The form {n, } matches n or more times. There is no limit to the size of
n or m, but large numbers will chew up more memory and slow down execution.

If a curly bracket occurs in any other context, it is treated as a regular character.
Examples:

count.*r B- matches strings like 'counter', 'countelkjdflkj9r' and 'countr'
count.+r - matches strings like 'counter', 'countelkjd£1kj9r' but not 'countr’
count.?r - matches strings like 'counter', 'countar' and 'countr' but not
'countelkjOr’

counte{2}r - matches string 'counteer’

counte{2, }r - matches strings like 'counteer', 'counteeer', 'counteeer' etc.

counte{2,3}r - matches strings like 'counteer', Or 'counteeer' but not 'coun-
teeeer'’

A little explanation about "greediness". "Greedy" takes as many as possible, "non-
greedy" takes as few as possible.

For example, 'b+' and 'b*' applied to string 'abbbbc' return 'bbbb', 'b+?'
returns 'b', 'b*>' returns empty string, 'b{2,3}?' returns 'bb', 'b{2,3}"'
returns 'bbb'.
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Metacharacters - Alternatives

You can specify a series of alternatives for a pattern using " |" to separate them,
so that bit|bat|bot will match any of "bit", "bat", or "bot" in the target string
as would "b(i|a|o)t)". The first alternative includes everything from the last pat-
tern delimiter (" (", "[", or the beginning of the pattern) up to the first " | ", and the
last alternative contains everything from the last " | " to the next pattern delimiter.
For this reason, it's common practice to include alternatives in parentheses, to min-
imize confusion about where they start and end.

Alternatives are tried from left to right, so the first alternative found for which the entire
expression matches, is the one that is chosen. This means that alternatives are not nec-
essarily greedy. For example: when matching rou|rout against "routine", only the
"rou" part will match, as that is the first alternative tried, and it successfully match-
es the target string (this might not seem important, but it is important when you are
capturing matched text using parentheses.) Also remember that " | " is interpreted
as a literal within square brackets, so if you write [bit|bat|bot], you're really only
matching [biao|].

Examples:

rou(tine|te) - matches strings 'routine' Or 'route’.
Metacharacters - Subexpressions

The bracketing construct ( ... ) may also be used for define regular subexpres-
sions. Subexpressions are numbered based on the left to right order of their open-
ing parenthesis. First subexpression has number "1’

Examples:

(int) {8,10} matches strings which contain 8, 9 or 10 instances of the "int’
routi ([0-9]|a+)e matches 'routile', 'routile’ , 'routine’,
'routinne', 'routinnne' etc.

Metacharacters - Backreferences

Metacharacters \ 1 through \ 9 are interpreted as backreferences. \ matches pre-
viously matched subexpression #.

Examples:

(.)\1+ matches 'aaaa' and 'cc'.

(.+)\1+ matches 'abab' and '123123"

(['"1?) (\d+)\1 matches "13" (in double quotes), or "4 (in single quotes) or 77
(without quotes) etc
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MIKROPASCAL PRO FOR AVR COMMAND LINE OPTIONS

Usage: mPAvr.exe [ -<opts> [ -<opts>]] [<infile> [ -<opts>]] [ -<opts>]]
Infile can be of * .mpas and *.mcl type.

The following parameters and some more (see manual) are valid:

-p : MCU for which compilation will be done.

-ro : Set oscillator [in MHZ].

-sp : Add directory to the search path list.

-N : Output files generated to file path specified by filename.
-B : Save compiled binary files (+ .mc1) to 'directory’.

-0 : Miscellaneous output options.

-DBG : Generate debug info.

-1 : Check and rebuild new libraries.

-DL : Build all files as libraries.

-v : Dynamic link for string literals.

Example:
mPAvr.exe -MSF -DBG -pATMEGA1l6 -011111114 -fo8 -
N"C:\Lcd\Lcd.mppav" -SP"C:\Program

Files\Mikroelektronika\mikroPascal PRO for AVR\Defs\"
-SP"C:\Program Files\Mikroelektronika\mikroPascal PRO
for AVR\Uses\LTE64KW\" -SP"C:\Lcd\" "Lecd.mpas" "_Lib Math.mcl"
"__Lib MathDouble.mcl"
" _Lib System.mcl" "__ Lib Delays.mcl"
" _Lib LedConsts.mcl" "__Lib Lcd.mcl”

Parameters used in the example:

-Mst : Short Message Format; used for internal purposes by IDE.

-DBG : Generate debug info.

-pATMEGAL6 . MCU ATMEGA16 selected.

-011111114 : Miscellaneous output options.

-fo8 : Set oscillator frequency [in MHZ].

-N"C:\Lcd\ Lcd.mppav" -SP"C:\ Program
Files\Mikroelektronika\mikroPascal PRO for AVR\defs\" : Output files gen-
erated to file path specified by filename.

-SP"C:\ Program Files\Mikroelektronika\mikroPascal PRO for AVR\Defs\"
: Add directory to the search path list.

-SP"C:\ Program Files\Mikroelektronika\mikroPascal PRO for
AVR\Uses\ LTE64KW\ " : Add directory to the search path list.

-sp"c:\Lcd\ " : Add directory to the search path list.

"Lcd.mpas" " Lib Math.mcl" " Lib MathDouble.mcl"
" Lib System.mcl" " Lib Delays.mcl" " Lib LcdConsts.mcl"
" Lib Led.mcl" : Specify input files.
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PROJECTS

The mikroPascal PRO for AVR organizes applications into projects, consisting of a
single project file (extension .mcpav) and one or more source files (extension ).
mikroPascal PRO for AVR IDE allows you to manage multiple projects (see Project
Manager). Source files can be compiled only if they are part of a project.

The project file contains the following information:

- project name and optional description,

- target device,

- device flags (config word),

- device clock,

- list of the project source files with paths,
- image files,

- other files.

Note that the project does not include files in the same way as preprocessor does,
see Add/Remove Files from Project.

New Project

The easiest way to create a project is by means of the New Project Wizard, drop-

down menu Project » New Project or by clicking the New Project Icon .:L from

Project Toolbar.
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New Project Wizard Steps

Start creating your New project, by clicking Next button:

MNew Project Wizard

Welcome to the New Project
Wizard

This wizard helps you:

e Create a new project

s Select the device for your project

¢ Setup device clock and choose device flags
e Select desired memory model

e Add project files

Click Next to continue

Back Mext 5 Cancel

Step One - Select the device from the device drop-down list.

Mew Project Wifizard =3

Select the dewvice you want to use,

Device Mame: ATMEGALG -

4@ Back Mext 5 Cancel
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Step Two - Enter the oscillator frequency value.

MNewy Project Wizard

(5]

Setup the clock, for example 11,0592 MHz.

Dewvice Clock: 11.0592EID| MHz

4@ Back

Next & Cancel

Step Three - Specify the location where your project will be saved.

MNews Project YYizard

553
Specify where your project will be saved,

Project File Name:

3\ Projecks|Fir stProjectiFirstPraject . mppav|

4 Back Next o

Cancel
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Step Four - Add project file to the project if they are avaiable at this point. You can
always add project files later using Project Manager.

MNews Project YYizard @

Add project files if they are available at this point.
vou can always add project files |ater using the Project Manager in IDE.

Add File To Project:

[n\Projects|FirstProjectDefinit. mpas E
Filz Mame
[\ProjectsiFir stPraject\Definit. mpas
Remove
Remove All
4 Back Next o Cancel
Step Five - Click Finish button to create your New Project:
MNews Project YYizard @

Step 575

You have successfully created a new project. Click Finish to save the changes
and to close the wizard.

=

N

4 Back _ Finish cancel

Related topics: Project Manager, Project Settings Customizing Projects
Edit Project
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CUSTOMIZING PROJECTS
Edit Project

You can change basic project settings in the Project Settings window. You can
change chip and oscillator frequency. Any change in the Project Setting Window
affects currently active project only, so in case more than one project is open, you have
to ensure that exactly the desired project is set as active one in the Project Manager.

Managing Project Group

mikroPascal PRO for AVR IDE provides covenient option which enables several
projects to be open simultaneously. If you have several projects being connected in
some way, you can create a project group.

The project group may be saved by clicking the Save Project Group Icon % from
the Project Manager window. The project group may be reopend by clicking the
Open Project Group Icon &% .All relevant data about the project group is stored in
the project group file (extension .mpg)

Add/Remove Files from Project
The project can contain the following file types:

- .mpas source files

- .mc1 binary files

- .pld project level defines files

image files

- .hex, .asmand .1st files, see output files. These files can not be added or removed
from project.

- other files
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Praject Manager &

%%L@L@ j_l & |GF E%
4-[74 TB963C_240x128.mppav
4] Sources
£ Te963C_240x128.mpas
% bitmap.mpas
=] Einaries
bitmapz .l
(1 Project level defines
=11 Image Files
sample.jpg
=i Cukput Files
2| TR963C_240x1258.hex
=] TRI63C_240x128.asm
% Te963C_Z40:128.Isk
=1 Other Files
£ DaTA - doc32ss.pdf

The list of relevant source files is stored in the project file (extension .mppav).

To add source file to the project, click the Add File to Project Icon .:‘J5 . Each added
source file must be self-contained, i.e. it must have all necessary definitions after
preprocessing.

To remove file(s) from the project, click the Remove File from Project Icon (= | .

See File Inclusion for more information.
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Project Level Defines
Project Level Defines (.p14) files can also be added to project. Project level define files

enable you to have defines that are visible in all source files in the project. One project
may contain several p1d files. A file must contain one definition per line, for example:

ANALOG
DEBUG
TEST

There are some predefined project level defines. See predefined project level defines

Related topics: Project Manager, Project Settings
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SOURCE FILES

Source files containing Pascal code should have the extension .mpas. The list of
source files relevant to the application is stored in project file with extension .mppav,
along with other project information. You can compile source files only if they are
part of the project.

Managing Source Files
Creating new source file

To create a new source file, do the following:

1. Select File » New Unit from the drop-down menu, or press Ctrl+N, or click the
New File Icon | | from the File Toolbar.

2. A new tab will be opened. This is a new source file. Select File » Save from the
drop-down menu, or press Ctrl+S, or click the Save File Icon |5 from the File
Toolbar and name it as you want.

If you use the New Project Wizard, an empty source file, named after the project with

extension .mpzs, will be created automatically. The mikroPascal PRO for AVR does

not require you to have a source file named the same as the project, it's just a mat-
ter of convenience.

Opening an existing file

Select File > Open from the drop-down menu, or press Ctrl+O, or click the Open File
Icon év from the File Toolbar. In Open Dialog browse to the location of the file
that you want to open, select it and click the Open button.

The selected file is displayed in its own tab. If the selected file is already open, its
current Editor tab will become active.

Printing an open file

1. Make sure that the window containing the file that you want to print is the
active window.

2. Select File » Print from the drop-down menu, or press Ctri+P.

3. In the Print Preview Window, set a desired layout of the document and click the
OK button. The file will be printed on the selected printer.
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Saving file

1. Make sure that the window containing the file that you want to save is the active
window.

2. Select File » Save from the drop-down menu, or press Ctrl+S, or click the Save
File Icon = from the File Toolbar.

Saving file under a different name

1. Make sure that the window containing the file that you want to save is the active
window.

2. Select File » Save As from the drop-down menu. The New File Name dialog will
be displayed.

3. In the dialog, browse to the folder where you want to save the file.

4. In the File Name field, modify the name of the file you want to save.

5. Click the Save button.

Closing file

1. Make sure that the tab containing the file that you want to close is the active tab.

2. Select File » Close from the drop-down menu, or right click the tab of the file that
you want to close and select Close option from the context menu.

4. If the file has been changed since it was last saved, you will be prompted to save
your changes.

Related topics:File Menu, File Toolbar, Project Manager, Project Settings,

MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD 81



CHAPTER 2
Environment mikroPASCAL PRO for AVR

CLEAN PROJECT FOLDER
Clean Project Folder

This menu gives you option to choose which files from your current project you want
to delete.

Files marked in bold can be easily recreated by building a project. Other files should
be marked for deletion only with a great care, because IDE cannot recover them.

Clean Project Folder (3]

Below is the list of all files in the project folder. Files in bald are those
generated by the compiler and they can be easily recreated when the
project is rebuilt,

Select which files you want to remove from the project folder, Please
naote that selected files will be permanently deleted from yvour dislk if

- [¥] spiEthernet.asm ~
-[] SpiEthernet.mpas

-] =piEthernet. mpas.ini

-[7] spiEthernet.cp

-.[#] spiEthernet.dbg

-[¥] SpiEthernet.dct

- [¥] spiEthernet.dit

-] spiEthernet.hex

-[¥] SpiEthernet.lst

-] spiethernet . mel

- [ spiEthernet.mppay

-[¥] SpiEthernet.mcproj_callertable.txt
- [¥] spiEthernet.mil

- [ spiEthernet.user . dic

Clean Cancel

ChProgram FilesvhikroelektronikamikroPascal PRO for S4WRY
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Compilation

When you have created the project and written the source code, it's time to compile
it. Select Project » Build from the drop-down menu, or click the Build Icon |#% from
the Project Toolbar. If more more than one project is open you can compile all open
projects by selecting Project » Build All from the drop-down menu, or click the Build
All Icon _i‘:.h, from the Project Toolbar.

Progress bar will appear to inform you about the status of compiling. If there are some

errors, you will be notified in the Error Window. If no errors are encountered, the
mikroPascal PRO for AVR will generate output files.

Output Files
Upon successful compilation, the mikroPascal PRO for AVR will generate output files

in the project folder (folder which contains the project file .mppav). Output files are
summarized in the table below:

Format Description File Type
Intel HEX Intel style hex records. Use this file to program AVR MCU. | . hex
Binary mikro Compiled _Library. 3inary distril?ution of applica- el

tion that can be included in other projects.
List File Overview of AVR memory allotment: instruction Lot

addresses, registers, routines and labels.

Human readable assembly with symbolic names,

Assembler File extracted from the List File.

Assembly View

After compiling the program in the mikroPascal PRO for AVR, you can click the View
Assembly icon [l or select Project > View Assembly from the drop-down menu to
review the generated assembly code (.zsm file) in a new tab window. Assembly is
human-readable with symbolic names.

Related topics:Project Menu, Project Toolbar, Error Window, Project Manager, Project
Settings

MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD 83



CHAPTER 2
Environment mikroPASCAL PRO for AVR

Compiler Error Messages:

- "ss" is not valid identifier.

- Unknown type "2s".

- Identifier "<s" was not declared.

- Syntax error: Expected "<s" but "<s" found.

- Argument is out of range "%s".

- Syntax error in additive expression.

- File "%s" not found.

- Invalid command "2s".

- Not enough parameters.

- Too many parameters.

- Too many characters.

- Actual and formal parameters must be identical.

- Invalid ASM instruction: "=s".

- Identifier "=s" has been already declared in "2s".

- Syntax error in multiplicative expression.

- Definition file for "<s" is corrupted.

- ORG directive is currently supported for interrupts only.
- Not enough ROM.

- Not enough RAM.

- External procedure "<s" used in "2s" was not found.
- Internal error: "<s".

- Unit cannot recursively use itself.

- "2s" cannot be used out of loop.

- Supplied and formal parameters do not match ("2s" to "ss").
- Constant cannot be assigned to.

- Constant array must be declared as global.

- Incompatible types ("ss" to "ss").

- Too many characters ("%s").

- Soft_Uart cannot be initialized with selected baud rate/device clock.
- Main label cannot be used in modules.

- Break/Continue cannot be used out of loop.

- Preprocessor Error: "ss".

- Expression is too complicated.

- Duplicated label "<s™.

- Complex type cannot be declared here.

- Record is empty.

- Unknown type "2s".

- File not found "2s.

- Constant argument cannot be passed by reference.

- Pointer argument cannot be passed by reference.

- Operator "2s" not applicable to these operands "2s".
- Exit cannot be called from the main block.

- Complex type parameter must be passed by reference.
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- Error occured while compiling "%s".

- Recursive types are not allowed.

- Adding strings is not allowed, use "strcat" procedure instead.

- Cannot declare pointer to array, use pointer to structure which has array field.
- Return value of the function "<s" is not defined.

- Assignment to for loop variable is not allowed.

- "3s" is allowed only in the main program.

- Start address of "2s" has already been defined.

- Simple constant cannot have fixed address.

- Invalid date/time format.

- Invalid operator "ss".

- File "< is not accessible.

- Forward routine "=s" is missing implementation.

- ;" is not allowed before "else".

- Not enough elements: expected "=s", but "2s" elements found.
- Too many elements: expected "<s" elements.

- "external" is allowed for global declarations only.

- Destination size ("2s") does not match source size ("3s").

- Routine prototype is different from previous declaration.

- Division by zero.

- Uart module cannot be initialized with selected baud rate/device clock.
- 2 cannot be of "ss" type.

Warning Messages:

- Implicit typecast of integral value to pointer.

- Library "<s" was not found in search path.

- Interrupt context saving has been turned off.

- Variable "2s" is not initialized.

- Return value of the function "<s" is not defined.
- Identifier "<s" overrides declaration in unit "2s".

- Generated baud rate is "=s" bps (error = "3s" percent).
- Result size may exceed destination array size.
- Infinite loop.

- Implicit typecast performed from "2s" to "2s".

- Source size ("2s") does not match destination size ("3s").

- Array padded with zeros ("2s") in order to match declared size ("%s").
- Suspicious pointer conversion.

Hint Messages:

- Constant "<s" has been declared, but not used.

- Variable "=s" has been declared, but not used.
- Unit "ss" has been recompiled.
- Variable "=s" has been eliminated by optimizer.

- Compiling unit "2s".

MIKROELEKTRONIKA - SOFTWARE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD 85



CHAPTER 2
Environment

mikroPASCAL PRO for AVR

SOFTWARE SIMULATOR OVERVIEW

The Source-level Software Simulator is an integral component of the mikroPascal
PRO for AVR environment. It is designed to simulate operations of the AVR MCUs
and assist the users in debugging Pascal code written for these devices.

After you have successfully compiled your project, you can run the Software Simu-
lator by selecting Run > Start Debugger from the drop-down menu, or by clicking
the Start Debugger Icon E@ from the Debugger Toolbar. Starting the Software Sim-
ulator makes more options available: Step Into, Step Over, Step Out, Run to Cursor,
etc. Line that is to be executed is color highlighted (blue by default).

Note: The Software Simulator simulates the program flow and execution of instruc-

tion lines, but it cannot fully emulate AVR device behavior, i.e. it doesn’t update
timers, interrupt flags, etc.

Watch Window

The Software Simulator Watch Window is the main Software Simulator window which
allows you to monitor program items while simulating your program. To show the Watch
Window, select View > Debug Windows » Watch from the drop-down menu.

The Watch Window displays variables and registers of the MCU, along with their
addresses and values.

There are two ways of adding variable/register to the watch list:

- by its real name (variable's name in "Pascal" code). Just select desired
variable/register from Select variable from list drop-down menu and click the Add
Button == Add

- by its name ID (assembly variable name). Simply type name ID of the variable/reg-
ister you want to display into Search the variable by assemby name box and
click the Add Button == add

Variables can also be removed from the Watch window, just select the variable that

you want to remove and then click the Remove Button $# Remove

Add All Button 4 Add All  adds all variables.

Remove All Button & Remowve &ll removes all variables.
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You can also expand/collapse complex variables, i.e. struct type variables, strings...

Values are updated as you go through the simulation. Recently changed items are

colored red.
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Double clicking a variable or clicking the Properties Button

) Properties  opens

the Edit Value window in which you can assign a new value to the selected

variable/register. Also, you can choose the format of variable/register representation

between decimal, hexadecimal, binary, float or character. All representations except

float are unsigned by default. For signed representation click the check box next to

the Signed label.
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